跳转到主内容

Model M5884 / 400 or 500 MHz G4 processor

23 个问题 查看全部

No power

Dear all,

my beloved PowerBook Titanium does not want to power up. Battery is ok as well as power supply. Any idea?

回答此问题 我也有这个问题

这是一个好问题吗?

得分 3
1条评论

Have the same problem. Tried resetting and still nothing.

完成的

添加一条评论

3个答案

最有帮助的答案

Try looking here: http://support.apple.com/kb/HT1431#faq8

Resetting the PMU might do the trick. I know the ol' Titanium is sweet, but it also might be time to look at a newer model.

这个答案有帮助吗?

得分 2
添加一条评论

It could be your DC-in board. The best way to test it would be to slide in another battery that has a charge to it... if the computer turns on, it is most likely your DC-in board. You can purchase one here if you are interested:

[关联产品丢失或禁用: IF133-010]

And you can look at the repair guide here:

PowerBook G4 Titanium DVI DC-In Board Replacement

这个答案有帮助吗?

得分 1

1条评论:

Beware Tyler's solution does not apply to the Mercury Model. The Mercury doesn't have a separate DC-in board.

完成的

添加一条评论

Try taking out your PRAM battery, shown in the remove PMU guide (it's the big thing marked 616-0114-A)

Disconnect the tri color lead from that to the PMU, start up the PowerBook (it should now work), then reconnect that cable and hopefully you should be left with a functioning PowerBook !

这个答案有帮助吗?

得分 1

2条评论:

So, disassemble to step 16, disconnect the tri color lead, reassemble, turn on computer. Disassemble to step 16, reconnect tricolor lead, then reassemble? Is that correct? Why would this work?

完成的

完成的

添加一条评论

添加你的答案

Emerenziano 将永远感激不已
浏览统计数据:

过去 24 小时: 0

过去 7 天: 0

过去 30 天: 1

总计 7,271