跳转到主内容

修复你的物品

维修的权力

配件 & 工具

Released October 24, 2011 / 2.2, 2.4, or 2.5 GHz Quad-core Intel Core i7 Processor

392 个问题 查看全部

Totally Unresponsive - SMC Dead?

MD322LL/A (Late 2011 MBP 8,2) running El Cap.

Was using it in the Anchorage airport. Went outside to smoke. Came back in. Laptop had turned itself off while we were outside, which seemed odd but whatever.

Used it for a few more hours, then traveled from the one airport to another, which entailed two heated bus rides along with maybe a total of an hour outside.

Got to the other airport and the thing was totally dead. It won't boot, there's no pulsing status indicator light, it won't report battery level (which was full when I left the airport) via the little button on the side, and the light on the magsafe won't turn on when attached. I've never seen a laptop so dead.

I'm thinking the temperature back-and-forth in Anchorage thrashed something, and given that the SMC controls the power button, SIL, battery management, and battery indicator light, it is my prime suspect.

I read somewhere (damned if I can find it again, though) that the SMC is powered by a battery on the logic board. And I know that cold is rough on batteries. My hope is that it's a common button cell that can be easily replaced. But I could be on the totally wrong track here.

Is there any hope of repairing this, or is it new logic board i.e. new mac time?

Edit: FWIW, I've tried SMC reset via the standard procedure for macbooks with "non-removable" batteries (shift-ctrl-option-power, as well as the older procedure (power button for 10 sec) by opening up the bottom and disconnecting the battery. No effect. Also went through the motions of a PRAM reset, just for kicks. No change.

Magsafe charger is known to be good. Main battery status is unknown, but I'd think that it could boot via magsafe power regardless.

Update: I tried disconnecting the battery, then booting on magsafe power, to check if a faulty battery was interrupting the power circuit or whatever. No change.

Tried bypassing the power button by shorting the solder pads, both with keyboard attached and detached. No change.

已回答! View the answer 我也有这个问题

这是一个好问题吗?

得分 3

评论:

@mayer might be able to help.

完成的

Check the MagSafe connector on the computer for debris. Often a simple cleaning can do wonders here.

完成的

Surely a dirty magsafe would not prevent it from booting off of a battery I know to be full...

But yes, I clean the magsafe regularly. That is not the problem.

完成的

添加一条评论

LCD iPhone 屏幕维修套装

预算选项,涵盖在我们的终身保修中。

购买套装

LCD iPhone 屏幕维修套装

削减维修成本,而不是质量。

购买套装

1个回答

已选择的解决方案

If the systems battery tester is showing only a few or no LED's that tells me the battery is drained. This could be caused by a few issues besides a dead battery. As you stated you disconnected it and the system still won't boot (using the power pads as well) we need to focus on the MagSafe adapter and the AC power side of the issue.

  • What is the color of the MagSafe adapters LED Amber or Green?
  • Do you have a second MagSafe unit?

Follow this Apple T/N to inspect the connection and to make sure you have the correct unit: Apple Portables: Troubleshooting MagSafe adapters

  • If that all checks out then you likely have a logic board level issue which will need someone with deeper skills and access to the needed parts.
  • If you note the systems connector is damaged then you may need to replace the MagSafe DC-In Board. Follow this IFIXIT guide: MacBook Pro 15" Unibody Late 2011 MagSafe DC-In Board Replacement I'll warn you its a bit of work.

One issue which is rare is a bad battery tester (shorted) you might want to disconnect it to make sure thats not your issue. You'll find it here in this guide on Step21 MacBook Pro 15" Unibody Late 2011 Logic Board Replacement

MacBook Pro 15" Unibody Late 2011 Logic Board图片

指南

MacBook Pro 15" Unibody Late 2011 Logic Board Replacement

难度:

中等

50 minutes

MacBook Pro 15" Unibody Late 2011 MagSafe DC-In Board图片

指南

MacBook Pro 15" Unibody Late 2011 MagSafe DC-In Board Replacement

难度:

困难

45 minutes

这个答案有帮助吗?

得分 2

评论:

The battery indicator on the side of the laptop shows no LEDs. Not even the single flashing one it usually shows when the battery is drained. The OS showed the battery as full no more than an hour before I found the computer to be nonresponsive. Is it possible for a battery to drain that quickly for no reason? Is there a voltage test I can do to the pins on the battery cable to see if it's got charge?

The magsafe light does not come on at all. Not even dimly. I've tried two adapters. Same result for both. I have thoroughly inspected the magsafe plug for damage/wear/stuck pins/etc. Is there a voltage test I can do to verify that the magsafe is providing the proper charge?

The magsafe port looks fine (clean and free of scorching). I also replaced the DC-In board less than 6 months ago, so it'd suck if it failed already. I could try, though. It's a cheap enough part.

I can also try disconnecting the battery tester. It's something I haven't tried, at least.

Thanks for the tips. I'll report back.

完成的

Joshua - There's lots of locations to measure power. But I can't point to the locations in this forum. This is where getting a set of schematics and board view drawings are needed. Besides you need to be able to understand what they are telling you.

At this point I'm suspecting you have a shorted MOSFET which is why your battery is drained if disconnecting the battery tester doesn't alter things.

完成的

Well, I finally cracked into the thing, and it's a MOSFET alright: https://imgur.com/a/TH1ZB

Part details are in the description.

I also saw this component which looks like it might be damaged as well, but to me it's less obvious. That really does look like melted plastic, though: https://imgur.com/a/fXyuE

Details, again, in the description.

At this point, I suspect water damage due to condensation that formed while walking in and out of the Alaskan cold.

I also suspect that this is way outside reasonable DIY territory...

完成的

Sorry for the bad luck. Don't forget to score & accept the answer.

完成的

The answer itself didn't contain the solution, but the comment pointed me toward the world of schematics and boardviews, which helped me identify components once I spotted the damage, and you ended up being right about the MOSFET. ifixit's reputation system, as far as I can tell, doesn't allow for such nuance though, so there ya go.

完成的

添加一条评论

添加你的答案

Joshua Vande Walle 将永远感激不已
浏览统计数据:

过去的24小时: 22

过去的7天: 158

过去的30天: 623

总计 10,974