The April 2014 update of Apple's 13" MacBook Air features refreshed dual-core i5 and i7 processors, plus slightly increased battery performance.

177 个问题 查看全部

MacBook Air 13” (2014) – Water Damage, will not power on

Hi everyone. I have a water damaged (tea) MacBook Air that was dead as a doorknob. No light on the MagSafe, no fan or anything. A visual inspection of the logic board (820-3437-B) showed no classical water damage (corrosion) but the backlight diode (D7701) was literally blown off the board (replaced). The LVDS connector however is in excellent condition. I also found a burnt pin on the I/O Flex (821-1722-A), which I repaired.

So after all of this, the Green MagSafe light comes on and then turns orange to show that the battery is charging.

Voltage Rails:

PP3V3_G3H measures 3.4V

PPBUS_G3H measures 8.6V

The SO, S3 & S5 rails are present.

Despite all of this, the computer will not power on so I’m starting to think it is a keyboard issue but I’m reluctant to order an expensive replacement upper case just to test. Is there any way to test (or circumvent) this keyboard? Do you have any other troubleshooting ideas?

@mayer @oldturkey03 @danj @reecee @rany

EDIT 2017-05-30

Thanks everyone for the help. I goit the MBA fully booted and started configuring it. @reecee nailed it with having me probe ALL_SYS_PWRGD and I found a U1950 Dual AND Gate IC that had a cold (or corroded) solder joint. I replaced it and the MBA booted!

Block Image

The last issue is getting it to switch from AC to battery without shutting down. I have created a new question (Shuts down when disconnected from AC)

已回答! View the answer 我也有这个问题


按维修分数 3


have you tried the power on contacts on the motherboard? They work pretty well when the keyboard doesn't


所有超过US$100或包含 Pro Tech工具包的订单免费送货!




This model will boot when the charger is plugged in, if you are getting no fan spin but the S0 rails are present, check ALL_SYS_PWRGD to see if this is present (and the signals U1950 produces for the PCH). Plug the charger in with literally nothing except the I/O board plugged in.

If the CPU is not getting hot, it is likely this signal or another signal for the CPU is missing, check out U7200 too. Likely has been messed with before, so check for any clues on the board indicating past water damage (brown probe points, flux residue, etc).

I won't repeat everything mentioned in the other answers, pretty much covers it and you have got the basics down from doing iPhone board repair. Good luck :)


按维修分数 4


My fan spins and the S0 rails are present. For all intents and purposes, it looks like the computer has booted except for the lack of the backlight rail.

I checked U1950 and there is something strange. ALL_SYS_PWRGD and CPUVR_PGOOD_R are both high (3.3V) yet the output of the AND gate is 0V.

I removed R1963 to see if the PM_PCH_PWROK line was pulling it down but that is not the problem. I removed U1950 and sure enough the power pin was not making contact (corrosion). I cleaned up the contacts and scavenged a U1950 from a donor board but now my PCUVR_PGOOD_R line is low so I am thinking that the AND gate may also be bad on the donor board (it was a little grungy).

I'll order a clean one if I can find it and get back to you.

@refectio If the fan spins and S0 rails are present, plug in the trackpad cable (with the keyboard and SSD connected) and press the caps lock key after 30 seconds, and if it is lighting up it is getting into an OS (meaning it is a backlight issue), if it is not, it isn't passing POST. You can also plug in a USB mouse to check this, if it lights up after a bit, it will be a backlight issue.

Sounds like it might not be passing POST, try a new U1950 and let us know how it goes :)


First clean the board, even if you cont "see" anything doesn't meanie's not there.

How to Correctly clean corrosion from a MacBook Pro logic board.

I aslo have a question, what end of the flex cable was damaged? Logicboard end or I/O end?

There is no reason to buy an entire uppercase, we always opt for keyboard only replacements, they are a much better value and are easy to install.


按维修分数 5


Thanks for the link for the for the corrosion cleanup, I think I have that covered ;>)


I would disconnect everything, plug in fan, MagSafe DC in, genuine 60W adapter, and see if fan spins.

Then start adding elements until something comes up.

Also G3H 8.6V tested present on both sides of the fuse?

Also, the blown diode, did you test both pads for resistance to ground? And for continuity to the next component in line?


按维修分数 5


Hi Rany.

* Okay, so the motherboard, I/O board and fan connected to genuine MagSafe: Fan turns (slowly at first but then picks up speed)

* Same setup as above but now added battery: Fan turns (slowly at first but then picks up speed). 0V on PPVIN_S0SW_LCDBKLT

* Same setup as above but now added screen: Fan turns (slowly at first but then picks up speed). 0V on PPVIN_S0SW_LCDBKLT

F7700 has 8.57V on both sides. Tried shorting the Power on pads, no booting. The problem is that Q7706 isn't switching because both EDP_BKLT_EN & BKLT_PLT_RST_L are low (0V). PP3V3_S0 is measuring 3.3V so clearly the CPU is telling the system not to turn on the backlight (see U2071)

And yes, I checked both sides of the diode, no shorts and the circuit is continuous both upstream and downstream. I had changed U7701 (forgot to mention it) because I was concerned it might have blown as well, which apparently is fairly common.

Examine really really closely the feedback line from diode to b/l driver..

I can pin point more precisely when I get to my workshop in 5 hours.

You have tested with a flashlight through the apple to see if you have "no display" or "no backlight?"


Try for a spontaneous boot. Dis connect the battery and magsafe, Then hook the battery back up to the logic board. As soon as you connect the mag-Safe, you should get a boot.


按维修分数 4


Hi Mayer. I tried that but nothing happens on the screen (see my comments to Rany). I'm wondering if I should try an external monitor or if the lack of enabling the backlight is symptomatic of something else.


Block Image

Those are where the power on pads are.


按维修分数 3


you answer has been edited for being uncouth and demeaning. That's totally uncalled for

Thanks Cam, something about forests and trees ;>). Unfortunately, that doesn't solve my problem though.

@mayer, I can take some lighthearted ribbing but getting rid of it for posterity is the right thing to do.

@mayer i ment no harm by that. I just thought that sometimes when i fix things, i forget something really small that helps me solve my issue, and i though since minho was working on this, that he might have just completely forgot about that little test.

What would your mother say if she saw you writing that? Well, on this site, I'm mother.

@cam2363 and iRobot is Daddy. So mind your manners;-)




Minho 将永远感激不已

过去的24小时: 4

过去的7天: 19

过去的30天: 83

总计 1,893