跳转到主内容

Model A1046 or A1095 / 1280x854 screen resolution

164 个问题 查看全部

Screen will not light up unless external video is connected

Hi! I've got an odd 15" aluminum that will not show video on its own screen unless it is connected to external video, in which case it comes on, and the external screen works fine as well. I've tried cycling through the external display modes, and booting up in each one. I've tried resetting the PMU, which works, but the machine's PRAM will not reset -- it just sits on a black screen endlessly. It's a shame, because I think a PRAM reset would probably fix the issue. I've tried another topcase/keyboard. I've tried having a hard drive installed vs no hard drive.

Occasionally, just randomly, the screen will light up with no external video attached, but it seems to be about one of 10 attempts, and like I stated, randomly, and not in response to anything in particular.

I'd hate to conclude that this is a bad board, and it seems like there must be a fix. It seems as if something is "stuck". Anyone know how to reset the PRAM without the keyboard? There are power and PMU power-on pads, but none for PRAM that I know of.

Thanks

已回答! View the answer 我也有这个问题

这是一个好问题吗?

按维修分数 6
添加一条评论

3个回答

已选择的解决方案

Just a shot in the dark but may work, try disconnecting the PRAM battery, AC adapter and main battery and then reconnecting the PRAM first. I would think that that should clear the PRAM.

这个答案有帮助吗?

按维修分数 5

评论:

Awesome, thanks Mayer -- that did it! 30 seconds of the PRAM battery disconnected, and the screen now comes on regularly. I totally forgot this machine had a PRAM battery!

It's weird though -- while the battery was disconnected, I could reset the PRAM and it would chime, but when I re-connected the battery module, it wouldn't reset anymore (although the screen still comes on just fine, I assume because the PRAM has been reset). I assume there must be a defect with this particular battery module, so I'll have to try another one. That's a first for me with PB15s! Anyway, thanks again!

Awesome, it's nice to get a working answer for one of our own tough questions ;-)

UPDATE: It's doing it again, and with a different PRAM battery module. Oh well, I guess it might be the board after all. I might try another screen assembly. At least changing the PRAM battery seemed to work for a while, and was a good troubleshooting step.

添加一条评论

If you get it to power on and you get video to its own LCD, try just putting it in sleep instead of turning it off. Sleep mode uses only 3-4% of battery power overnight. Perhaps the LCD will remain normal when you next wake it up.

这个答案有帮助吗?

按维修分数 0

评论:

The problem is not that it doesn't recover from sleep or go to sleep, but that the screen is black when the machine is first powered on.

Yes, I meant that since you didn't power it off when you made it sleep, the LCD will be normal when you wake it up.

添加一条评论

I believe, if it's like mine, that the problem is a severed wiring harness to the display at the upper right corner of the computer case. I have the same issue and this computer is known for an issue of a bad hinge. I knew, and perhaps you felt it too, the a slight "crunch" in the area of the hinge every time I opened and shut the lid was that it was gnawing on the wiring and sure enough, in time, the screen went blank similar to yours? I'm looking for a way to replace the wiring harness but not much success. I've found the part for as cheap as $15 but no instruction as for replacement. If you find this may be your issue and come upon instructions, please let me know.

carartone@gmail.com

这个答案有帮助吗?

按维修分数 0

评论:

ok, if this is the problem, I found the fix here:

PowerBook G4 Aluminum 15" 1-1.5 GHz Display Data Cable Replacement

unless you're a computer repairman, throw your computer away.

添加一条评论

添加你的答案

rdklinc 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 3

过去的30天: 23

总计 3,984