跳转到主内容

The iRobot Roomba 870 is an automated robotic vacuum cleaner that is part of the iRobot inc. 800 series Roombas.

8 个问题 查看全部

Why is my Roomba 870 only running 20 Minuets?

Okay so i have a Roomba 870 & i also have a 560 ... i have been charging them and testing both to see the run times ... My 560 runs for an hour sometimes more ... But my 870 Dies with in 20 Minuets "( .... Ive done everything to troubleshoot this issue ... Ive switched batteries between the 560 & 870 ... 870 still dies even tho the 560 ran on that battery for over an hour ... Ive even bought a brand new battery ... still dies in 20 minuets ... i have used 2 different docking stations, which work fine on my 560 and they do charge the 870 so i know that can't be the issue ... I have done the 30 Second reset holding the power button with the battery in & out ... I am loosing my mind trying to figure this out, If anybody has fixed this or knows WTH is going on PLEASE PLEASE PLEASE Help me out !!!

回答此问题 我也有这个问题

这是一个好问题吗?

得分 2
添加一条评论

2个答案

最有帮助的答案

@roomba870owner  I don't think we have enough information here. You need to let us know the exact specs of the batteries as well as the charger. In order to determine what is going on you need to attach an ammeter and see what amperage your iRobot’s draw and see what the difference is within each. For now, I suspect that you are using the same battery in different Roomba's that may have different power requirements, so you should not expect the same "runtime". Let us know what you find.

这个答案有帮助吗?

得分 1

7条评论:

I have used an XLife Roomba Battery & i Have Used a Brand New Black Roomba Battery 14.4V R3 Series ... Both batteries have the same result short run time even tho they are completely different ... The 870 comes standard with the XLife Battery .... Originally it had a completely dead/broken XLife Battery in it ... So i switched it with a New XLife Battery & when that did not work I Tried The Black Battery .... Both Are OEM iRobot Batteries ... & The Dock Charger is a Model 17070

完成的

You have tried to reset you Roomba I am sure. Just in case

Turn on your Roomba by pressing on the “Clean” button.

Press on the “Spot” and “Dock” simultaneously for 10 seconds.

Release the buttons at the same time.

You will hear the typical starting sound of the Roomba.

Put your Roomba to charge until the green light of “Clean” button is lit.

完成的

i have not done that reset ... the only reset i was told about was taking out the battery and holding the power button for 15 seconds ... I will give that reset a try & let you know if it works thank you ")

完成的

Okay so i tried that Reset method ... Holding (Dock & Spot) it says online it is suppose to turn off and do a Jingle ... But it shows me a Code Arc and then another Per ... What does this mean ?

完成的

It's a configuration issue. If you press the spot key over 5 seconds the word 'ArC' appears on the display. This means the robot moves in circles if it detects much dirt (dirt detection 1). If the word 'PEr' shows up, the robot moves forward and backward (dirt detection 2). I believe you can toggle this off by holding the Spot key down again for longer than 5 sec.

完成的

显示更多的2条评论

添加一条评论

Mine is the 800 seiries. It had a short run cycle, going dead quickly and not cleaning well. It recharged to green in less than 2 hours. I tried all of the tips I found online for a through cleaning and battery reset. My cure was that I found lots of hair inside the roller brushes- under the yellow cap on thier axle. This was a big power drain. The yellow cap pulls off and the post that it was attached to pulls off. This allows access to the gunk. I did check the other end of the brush rollers. That side does not seem to come apart, but I was able to see inside and it was clean. I also ised a needle to clean out a wad from under each rubber tire. Our Roomba works now.

这个答案有帮助吗?

得分 0
添加一条评论

添加你的答案

Nicholas 将永远感激不已
浏览统计数据:

过去 24 小时: 2

过去 7 天: 7

过去 30 天: 33

总计 4,588