A series of 40 inch LCD HDTVs by Sony.

149 个问题 查看全部

No picture, just green light

When I turn on my 40 inch Sony Bravia, the tv clicks and the green light comes on. I don’t have any picture or sound. I’ve been told to shine a light in the dark to see if I can see the picture. I tried it and light just reflects off screen. I can’t see any picture. Any suggestions? Could it still be the inverter board? It was working fine, then one day no picture. No warning signs before it happened.

=== Update (04/10/2018) ==

Here is a picture of the whole back and each board. It is model KDL-40S504. I have a multimeter as well.

Block Image

Block Image

Block Image

Block Image

Update (04/11/2018)

I tried to see if it was in standby mode. It didn’t work when putting in the combo with the remote. Here is a picture of the T-Con board.

Block Image

已回答! View the answer 我也有这个问题

这是一个好问题吗?

按维修分数 2

评论:

This happens to mu TV everytime i play the you tube app.

I played YouTube off of my Sony tv and now the green light turns on but I get no picture or sound. I know nothing about TVs or how to even take the back off of it. I need help!!!

erika.ingerson make and model of your TV?

添加一条评论
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

3个回答

已选择的解决方案

@joebrown this does not sound like a backlight error from a failed inverter etc. You most likely would have audio with it. Your error sounds like a bad power board since you have neither. Let us know what exact model this is and post some pictures of your boards with your question. You'll need some basic tools and a multimeter to test things later on.

Update (04/10/2018)

@joebrown see if you can put the TV into diagnostics mode:

1. TV must be in standby mode. (Power off).

2. Press the following buttons on the Remote Commander within a second of each other:

DISPLAY==> Channel 5==> Volume + ==>TV POWER .

The Self Check list displays.

NOTE: This is the same as accessing Service Adjustments.

3. To display the Self Diagnostic list, press +

If this works let us know if it displays any "1" under diagnostic information

I need one more picture of the T-con board. That is the board on top of the TV where the cable from the main board plugs into. There will be a fuse on that and we need you to measure continuity of the fuse and later power to the fuse when you turn the set on. You also want to post some more images of the boards just zoom in a bit more so we can check the components closer.

Update (04/12/2018)

Block Image

check the fuse for a. continuity. After that check to see what the voltage is on it when you turn your set on. Red probe on either side and Black probe on chassis ground meter in VDC

这个答案有帮助吗?

按维修分数 2

评论:

I tested the T-con board fuse you suggested and it had 25 volts when I powered on the TV. Any suggestions from there?

okay so you do have power to the T-con board. Can you check on your power supply connector CN6701 for the proper voltage going to the balancer board?

Yes. How do I do that? I checked the C6701 on the power supply board and it has 25 volts as well. I couldn’t find the CN6701.

Sorry that was supposed to be C6701. okay so your balancer board gets power as well. Let me try and find out where to check the voltage on that board

Thankyou, now up and working 5, +volume, on

显示更多的2条评论

添加一条评论

Hi friend, i has the same problem and i solve it replacement the EEPROM programes with the last firmware if ur TV model. This problem ( green led on bucle) its cause for a corrupt memory.

这个答案有帮助吗?

按维修分数 0

评论:

That did not work.

添加一条评论

Oldturkey, let me know if you have suggestions on what to do next to check the balance board or any others.

这个答案有帮助吗?

按维修分数 0
添加一条评论

添加你的答案

Joe Brown 将永远感激不已
浏览统计数据:

过去的24小时: 87

过去的7天: 555

过去的30天: 2,677

总计 14,196