跳转到主内容

修复你的物品

维修的权力

商店

Model A1419 / Late 2013 / 3.2 & 3.4 GHz Core i5 or 3.5 GHz Core i7 Processor, ID iMac14,2

313 个问题 查看全部

Replaced HD with SSD, now get startup chime but only black screen

I replaced the internal HD with a 1TB Crucial MX500 SSD and used the OWC Complete Hard Drive Upgrade Kit and NewerTech AdaptaDrive to complete the upgrade. This was the fist time I opened my iMac and I was careful to follow the steps from both iFixit and OWC. Got every thing back together but when it boots I hear the startup chime and only get a black screen and a very loud fan (never heard it that loud before). I've tried the following keys at startup:

  • Option (Startup Manager, with a bootable USB thumb drive plugged in)
  • D (Apple Diagnostics utility)
  • Command-R (built-in macOS Recovery)
  • Option-Command-P-R (reset NVRAM)

But the screen never comes on. The new SSD should be fine — I used Carbon Copy Cloner to make a bootable clone of the previous internal HD and booted from the cloned SSD using an external USB enclosure to make sure it worked.

Is there anything else I can check before I pull the screen off again and start checking connections? Once I've done that, what should I do to make sure it boots before sticking the screen back on (don't want to keep buying adhesive strips)? Thanks!

已回答! 显示答案 我也有这个问题

这是一个好问题吗?

得分 3
添加一条评论

1个回答

已选择的解决方案

iMacs have a very delicate video cable that connects to the logic board.

I would say, hold down "Option" when turning on the iMac.

If you still don't see anything, not even a gray screen, it is highly likely that the cable is loose or damaged.

Start with these, and maybe we can eliminate these as the issues.

Also, the kit comes with the special hard drive cable with thermal sensor, so I am not sure why you are experiencing the loud fan, unless the cable isn't in right or something else is wrong.

这个答案有帮助吗?

得分 2

评论:

I took the screen off again and found that the screen's cable was unplugged. Man, that thing is tiny and touchy! I also jiggled the cables connecting the hard drive; not sure if that did really anything but the fan no longer runs at full blast when it's powered on. Thank you for the assistance!

完成的

添加一条评论

添加你的答案

Paul 将永远感激不已
浏览统计数据:

过去的24小时: 5

过去的7天: 19

过去的30天: 100

总计 2,408