跳转到主内容

The 2004-2008 F-150 truck was introduced in January 2003 for the 2004 model year as the redesigned eleventh generation of the F-150 lineup.

56 个问题 查看全部

Wrench light error code P2135

Good morning. I have a 2008 f150 4.6 v8 xlt. For the past 7 months, my truck randomly produces an error code. P2135 Thottle/Pedal Position Sensor/ Swith A/B Voltage Correlation. The wrench lite comes on and the truck goes into limp mode. I can usually clear by a couple of methods: turning off the engine, disconnecting the battery, clearing the code, or clearing the computer (PCM). This is usually a quick fix, but the problem keeps coming back.

I brought it to a mechanic. He replaced the throttle body. A week later, the problem came back and I brought it back in. He replaced the throttle body again, thinking it maybe a defective part. Ran some diagnostics, and eliminated the pedal sensor, the throttle body. Determined that there were 2 bad coils, started by replacing spark plugs.

Problem still persisted. I changed out all 8 coils, put a new battery in(probably not related), unplugged the throttle sensor, the pedal sensor, the coil wires and the three cables going to the PCM. Waited a couple of minutes and plugged everything back in. Next, I cleared the PCM by disconnecting the negative cable from the battery and connected with an alligator clip to the positive pole on the battery for 15 minutes. Reconnected the battery, turned off all accessories, turned key on and let ignition run thru its beeps and then started the truck, let the truck idle for 15 minutes to relearn everything. This was effective for four months. Now the problem is back again and driving me crazy.

As far as I can tell, the issue began after the serpentine belt was replaced. Last weekend, I had to replace the tensioner pulley assembly. I was hoping I had found the issue.

The problem persisted after 4 days.

The error code is thrown in various situations, as I have tried to monitor what is going on when it happens. 1. truck is idling and heater is on

2. after running truck on highway for at least 10 minutes and get caught in traffic, truck idles at 1800 RPM’s

3. running A/C unit

4. traveling at 65–75mph on highway, no idling, or after idling in traffic

I have heard something about the air intake causing this problem, but have not researched yet…

I have guessed that it is some type of wiring issue, but not sure where to look.

Please help!!!

回答此问题 我也有这个问题

这是一个好问题吗?

得分 0
添加一条评论

3个答案

最有帮助的答案

I have a 2007 F150 4.2 v6 xlt. replaceed the spark plugs, wires, coil computer.

thottle body then took to ford they replaced the thottle body and pigtail and now

the code P2135 comes up on the code reader. wrench lite comes on and the

truck goes into limp mode. I can usually clear by a couple of methods: turning

off the engine, disconnecting the battery, clearing the code, or clearing the

computer (PCM). This is usually a quick fix, but the problem keeps coming back.

这个答案有帮助吗?

得分 1

1条评论:

New fuel sendin unit. Throttle positing sensor.not whole throttle body. From parts house like 3 years before with the one thats on there now has limp moded again. After brake issues.of wore out brakes. With big rims and tires. Havin to push brakes down hard to stop. Brake cylinder boot came off .all fluid and pressure.went out of trk.but now the trk has crunk up again.and idles.but no gas petal.orange wrench lite on.mines got elect wire conn. On brake petal.plus the sensor. Tps.was new but the passngr side.that turns rod and flapper. Was turned 5.6.7 times clock wise.tryin to crank. When it should be 1or 2 turns counter clock wise.from factory.and did it mess up the driver side sensor out of 180 degrs.which is suppose to break it .but trk did crank idle .no gas petal limpmode .can my 2004 ford f150 4,6litre xlt triton. Be fitted with a 2004 0r 05 5.4litre xlt triton .gas petal electronic wire harness plugs on it

完成的

添加一条评论

I have an 06 4.6 3v Mustang that's Modded so I know them pretty well, I had this same problem. Driving normal in my 07 Expy 5.4, started developing a rough idle and it would die down to an idle with the wrench light on (limp mode) it wouldnt react to the throttle at all. Pushing it into “N“, turning the key off and restarting it while still moving would reset it and it would be okay for a few days or a week. I cleaned the T-body and replaced the TP sensor. Still did it. I ended up having to do an entire timing job on it with all new Name brand Ford Phasers and M340HV Melling oil pump, new VVT solinoids, spark plugs and coils while I was at it. (Had a phaser noise is the only reason I did the timing, it wasn't related to the stalling, I dont believe) None of that was done to try to fix the prior concern. After replacing the entire T-body, a new Gas pedal fixed the problem. Its common, the throttle pedal is electronic with 3 bolts and one electrical connector. Easy fix……pretty rough diagnostics.

这个答案有帮助吗?

得分 1

1条评论:

Forgot to mention......With the timing noise, I also developed a P0351 #1 coil code that would not go away. I traced it back to the #17 pin of my PCM having a dead driver to the coil and swapped the PCM, had Ford transfer the software and that didnt fix the stalling out problem either.

完成的

添加一条评论

Check your oil level. This was the issue with my p2135 code on my 06 f150

这个答案有帮助吗?

得分 0
添加一条评论

添加你的答案

Tim 将永远感激不已
浏览统计数据:

过去 24 小时: 1

过去 7 天: 14

过去 30 天: 77

总计 6,917