跳转到主内容

Model A1419 / EMC 3070 / Mid 2017 / 3.4, 3.5 or 3.8 GHz Core i5 or 4.2 GHz Core i7 Kaby Lake Processor (ID iMac18,3) / Retina 5K display. Refer to the older iMac Intel 27" Retina 5K Display (Late 2014 & 2015) guides as the system is very similar.

211 个问题 查看全部

iMac won't boot after RAM upgrade

Hi

I installed 64GB of RAM into my iMac 4 x 16GB

After the upgrade the system fails to boot. I can hear the hard drive, however the screen is off, with the old RAM the iMac works as expected.

I have verified that the RAM is compatible and should work with my iMac.

Any solution to get the iMac to work with the new RAM?

已回答! 显示答案 我也有这个问题

这是一个好问题吗?

得分 13

评论:

Not much can be said without knowing the configuration. Some boards and processors have limitations on RAM size and speed, should also check if is it buffered or unbuffered, EDO or SD RAM. Try inserting a single module at a time.

完成的

Hi

I have the same problem. After installing 2 additional RAM sticks the iMac won't start anymore. In my case I could isolate the problem to be related to the 4th RAM socket.

If I keep the topmost RAM slot empty and I put some of my RAM sticks in the other three slots the iMac will start.

But if I install a RAM module in the 4th slot the iMac won't start anymore (even with the RAM modules from apple initially installed in slot 1+3).

Can it be that a RAM slot is broken on a new machine ???

Thanks for any help

Andreas

完成的

I have the exact same issue. I have determined that all the RAM sticks are functioning correctly but my second RAM slot from the bottom doesn’t seem to work. It’s a brand new machine. Is this a more common issue because I’m seeing this on a variety of different forms... going to schedule a repair from AppleCare but wow! Super annoying!

完成的

Brand new 27” iMac 5K and two of my four RAM slots are useless! When RAM is installed in either of the bad slots the machine fails to boot and screen stays dark.

Apple initially thought I bought bad after-market RAM, but after many swaps between the installed RAM and the two 16 GB sticks I bought in they agreed the slots must be bad.

Let’s see how long it takes them to repair or replace. Frustrating!

完成的

I also just purchased a 27” 5k 2017 iMac and have isolated the problem to be my 2nd from bottom RAM slot.

* The stock memory reads in slots 1 & 3

* The new memory reads in slots 1, 3 & 4

* The new memory and stock memory reads in slots 1, 3 & 4

But if anything is in slot two the machine will not boot at all.

Very frustrating! Just spent my life savings in this machine and for it to arrive broken is very upsetting!

完成的

显示更多的14条评论

添加一条评论

23个回答

已选择的解决方案

Ensure you have seated all RAM sticks properly in their slot, verified the keying matches and visually inspected the metal contacts between the RAM and the motherboard. There should no play in the installed RAM. This generally takes more force than is usually expected. Your system's symptom is typically that of no RAM installed. Check back with more information as it becomes available to you.

这个答案有帮助吗?

得分 6

评论:

Thanks for your quick response, I also read that the RAM had to be inserted fully. The Mac did not turn on because I had not seated the RAM all the way.

I pressed the RAM firmly into the slot and then again after closing the lever before testing, it worked perfectly.

完成的

Glad I could help. It's surprising how hard you have to push to get them memory sticks in. I'm always afraid I'm going to break them.

完成的

I have done the above twice, computer still dead, took the two new ram-sticks out, and computer is well again....

I should have the right ram, 2x16, pc4-19200 DDR4-2400 kit, from OWC....

完成的

After having talked with owc-chat, they asked me to press Cmd, Option and p and r, and then start the computer, and thát did the trick....

完成的

Had same problem. The above solutions did not work for me. BUT ... I did figure out the solution. After taking note of the original Apple RAM locations, remove the Apple RAM and put the new RAM modules into those original locations, then put the old Apple RAM into the previously empty slots. That worked for me. For some reason, the MAC wants Apple RAM in those originally empty slots - probably as a ruse to get you to buy Apple memory instead of less expensive OWC, Crucial or Vengeance RAM. Crucial works fine.

完成的

显示更多的8条评论

添加一条评论
最有帮助的答案

This thread was helpful. I had to try every combination of configurations, i.e. ram chips in different slots, until it worked.

I had 2 - 4GB OEM RAM chips installed in slot 1 and slot 3.

I bought 2 - 8GB OWC RAM chips and it finally worked in this configuration:

4GB/8GB/8GB/4GB

Machine is 27” iMac Retina

这个答案有帮助吗?

得分 9

评论:

Oh my God! After a weekend of trial and error and lots of online research, John's configuration worked for me!

I had watched the 9to5mac video https://www.youtube.com/watch?v=-YyPmGLH..., on the ease/$ savings of upgrading RAM in a 2017 iMac 27". I purchased the Corsair Vengeance 32GB RAM: http://amzn.to/2sTZtXh the author suggested via Amazon and installed 2x16gb sticks into blank slots 2 and 4 (I had 2x8gb OEM sticks in 1 and 3). The new configuration would bring me to 48gb of total RAM. Only problem was, it didn't work initially and was throwing my 2017 iMac 27 3.4 i5 (18.3) into an endless restart/reboot loop. I tried several re-installs/configuration changes and confirmed all sticks were seated properly but the problem persisted until I found this thread and John's post.

I had 2 -8GB OEM RAM chips installed in Slot 1 and Slot 3

I bought 2-16gb Corsair Vengeance RAM as outlined above and configured them like this:

8gb/16gb/16gb/8gb. IT WORKED!

My machine is 2017 iMac 5K Retina 27 3.4 i5 (18.3)

完成的

After reading through this page and trying all the suggestions, John's worked.

2x 8GB in slots 1 & 3.

Added 2x 16GB in slots 2 & 4, machine would not boot.

Reversed this and still did not boot.

Tried 8 - 16 - 16 - 8 and it booted, with all memory registered.

Thank you for saving what's left of my hair!

完成的

THIS. This is it! I tried several combinations and stumbled across your comment. I bought 2x16GB Vengeance 2400 to go along with the OEM 2x4 and installed it 4-16-16-4 and it worked!

完成的

BEAUTIFUL! John’s worked!! Whoop I don’t have to throw the MAC across the room. YES!

完成的

This configuration worked for me with Corsair Vengeance DDR4 ram on my 2019 “27 iMac after trying and failing several other configs:

4gb OEM

16gb Corsair Vengeance

16gb Corsair Vengeance

4gb OEM

完成的

显示更多的3条评论

添加一条评论

I had the same issue, mac not booting after RAM upgrade. I put the RAM sticks in the empty slots, but wouldn’t boot up. I took each of the new RAM out one by one and swapping them in the available slots, and figured that my second slot (from the bottom) is not working. I then decided to put the existing RAM in those sockets, to see if it does the same….nope, it booted. So then i added the new RAMs (in the sockets where the original sticks were) and it finally booted up and recognized all of them. Don’t know why it did this, but in the initial configuration it would boot with only one added stick in the top socket.

这个答案有帮助吗?

得分 3

评论:

Had same problem. The above solution worked for me too. Move the original Apple RAM to the empty slots and then add the new RAM to the slots where the original Apple memory was located.

完成的

This worked for my 20190 17" 5k iMac. I purchased 4x16Gb sticks and replacing them all at once resulted in black screen/no boot.

It appears - after a lot of trial and error - unused slots must be "primed" with used memory before working.

Staging the replacement by moving the two old 4Gb sticks to unused slots allowed a boot w/40G total.

Interestingly the memory initialization process was hosted by a progress bar and apple logo - not a black screen as apple support stated.

When I replaced the old sticks (now in top two slots) with new 16G sticks it would not boot.

Putting old sticks back in also did not work.

Removing old sticks from their new - top slot locations - worked with just bottom new ones.

Moving the bottom new sticks to top slots and adding remaining new ones to vacated bottom slots allowed boot with full 64G.

完成的

Worked for me too - iMac 27” late 2012 (OS Catalina).

Moved existing Apple 2x4 GB to the unused slots.

Started the iMac.

Inserted new 2x8GB on the used slots.

You must press the cards hard.

I now have 24 GB.

Many thanks to this forum!

完成的

添加一条评论

I read that it could take 30 seconds or more for the computer to initialize ram if some was added or the sticks rearranged. Did you wait at least 30 seconds after powering on with the new ram added?

这个答案有帮助吗?

得分 2
添加一条评论

I can only tell you what worked for me on my late 2009 iMac. After much frustration I pulled out the plastic tab all the way and at the same time inserted the new RAM with considerable force to make sure it was seated. Trust me you'll know when it's seated properly because it won't move at all.

这个答案有帮助吗?

得分 1
添加一条评论

Of course, the RAM slot can be DOA / broken.

If you have inserted a RAM stick in slot 4 and 1/2/3 it does not boot, and that stick works in slot 1/2/3 and you have inserted it properly it is perfectly possible.

You can also try resetting the SMC by disconnecting power and waiting 15 seconds and then plug it back in, wait another 5 seconds and turn it on.

And NVRAM / PRAM by turning off the mac and holding CMD+ALT/OPT+R+P and turn it on and hold until you see the progress bar. Please check Startup Disk, Display, and Date & Time settings as they may have been effected by the reset.

这个答案有帮助吗?

得分 0
添加一条评论

I had the same problem and tried every combo as well. I do believe the problem was it took longer to recognize the new ram and boot up. I just wasn’t giving it enough time. All is working great now with 64 GB ram installed

这个答案有帮助吗?

得分 0

评论:

How long? 10 min or like an hour?

完成的

添加一条评论

In my issue: I bought two sims Hyper with the same specs. except because they needs 1.2 volts. After a test a lot of combinations, iMac only work with the two OEM or with the two HYPER. It seems like OEM and HYPER are not compatibles.

这个答案有帮助吗?

得分 0
添加一条评论

I had the same exact problem.

I had to insert 4-16-16-4 and it worked.

Thanks very much!

这个答案有帮助吗?

得分 0
添加一条评论

Currently trying (& failing) at rebooting my iMac;

I’ve tried these patterns thus far with no luck,

4 - 4 - 8 - 8, &

4 - 8 - 8 - 4

*going to try holding alt, cmnd , r + p while rebooting, and waiting patiently (it’s taking forever, but I can feel the machine response and my USB lights up, just nothing, but a sad blank screen.

Thnx for the helpful thread !

这个答案有帮助吗?

得分 0

评论:

Yeah took me forever tried every combo finally worked for me putting in one at a time. Very stressful. I think just keep trying everything possible and doing it over and over till it recognizes it. Good luck it will work eventually.

完成的

添加一条评论

Hi Alishaa,

I had similar issues. I found that the key was to remove the old (original) RAM, put the new RAM into the old (original) RAM locations; and then put the old (original) RAM into the remaining slots.

这个答案有帮助吗?

得分 0

评论:

I have a couple of really lame questions: Does the manufacturer’s label face up or down? Also, are the slots numbered up and down or left to right?

完成的

添加一条评论

I tried to add 32 GB of ram today to my new 2019 iMac and it wouldn’t boot (black screen). It was Crucial 2x16 GB memory that I added to my pre-installed 2x4GB ram. I tried every which way, every configuration and nothing worked. The computer only booted up properly when the original ram was in there (in any slots) without the new ram. Any suggestions??? I’m ready to return the memory!!

这个答案有帮助吗?

得分 0

评论:

Thanks! Yay new iMac that’s exciting,! Honestly mine was a matter of the order they were placed

I did the preexisting 2 on the outer sides and the 2 new ones in the middle slots and rebooted. It worked after finding the right combo (weird)

完成的

Thanks....I’ve tried most configurations....but I will try a few more tomorrow before returning the memory. I’m not sure why it’s so difficult and why it needs to be in an exact order.

完成的

添加一条评论

had this issue to, was gonna try original ram but realized one was just slightly loose. tried again, and kept ALSO resetting PRAM (CMD+ALT/OPT+R+P) with a usb keyboard (not wireless keyboard it came with) finally worked and don’t have to return the ram :)

这个答案有帮助吗?

得分 0
添加一条评论

I realized you can’t mix different brands of memory cards. Problem solved.

这个答案有帮助吗?

得分 0
添加一条评论

Hello, I have the same problem.

I add 32gb ram to my iMac 2020 27 "

After installing the ram, I waited about 2 minutes for the machine to finish booting. And currently my iMac is running with 40gb ram.

I have read this message on the Apple’s support page:

Note: Your iMac performs a memory initialization procedure when you first turn it on after upgrading memory or rearranging DIMMs. This process can take 30 seconds or more, and the display of your iMac remains dark until it’s finished. Make sure to let the memory initialization complete.


这个答案有帮助吗?

得分 0
添加一条评论

I had a similar problem with my 2020 27” iMac with Retina display. But I moved the original two memory sticks and inserted the new one. Mac would not boot. So I put the original sticks back in their original spots and slipped the new 32MB stick in an open slot and it booted up just fine.

这个答案有帮助吗?

得分 0
添加一条评论

I have two owc sticks of ram and after install the computer beeps three times. While testing them both in the empty slots, I accidentally removed one stick of old ram. I put it back but my Mac won’t recognize it. I don’t know why.

这个答案有帮助吗?

得分 0
添加一条评论

After countless hours of troubleshooting, trying different RAM in different slots, and speaking to AppleCare…. The problem was the controller… The iMac had to have the whole motherboard replaced (because Apple doesn’t repair that one piece)

Thanks for your help everyone! Im surprised this thread had this much traction and I really appreciate all of the advice!

这个答案有帮助吗?

得分 0
添加一条评论

I have tried all sort of combinations moving from one slot to another in an IMAC 27 late 2014. I only managed to install 3 x 8gb Ram and after trying to install the last slot using the old 4gb RAM my Mac restarted with 3 beeps. So, I gave up and left my Mac with 24 gb instead of 32gb!

这个答案有帮助吗?

得分 0
添加一条评论

Today is December 30, 2020. My iMac 27” is 2019 Model with Inter i9 processor and 8 GBx2 RAM. I purchased 16GBx2 2666 MHz OWC RAM and installed following instruction video in Youtube. I couldn’t restart my iMac for many times. Later on, I pulled out the original two 8GB RAM and tried, time iMac started normally, with 32 GB new RAM. Then, I shut off iMac, re-installed the two 8GB RAM back, this time iMac started normally. Checked “About this Mac”, it showed “Memory 48 GB 2667 MHz DDR4”. I don’t understand why it is like this. But I am happy it works as expected. BTW, I purchased OWC RAM because some websites says Apple use OWC RAMS and I didn’t open Mac to check it before I purchase it from Amazon. It turned out original RAM is SK Hynix.

这个答案有帮助吗?

得分 0
添加一条评论

Hi,

I just bought my new 27"inch 5K iMac and I got the same problem, after installing 8GBx2 2666 Mhz from OWC I got dark screen too. I am going to try another combination today because yesterday I only removed the new memory sticks and it worked again, so I will update on this as soon as I try another combinations.

这个答案有帮助吗?

得分 0

评论:

I am in the same situation, just got my new 2020 27" installed 32GBx2 2666 Mhz DDR4 2666 and I only have a black screen for more than 5min. Let me know if you find a solution.

完成的

添加一条评论

I’ve solved this problem. first install the ram like this. SLOT 1 , 3 and 4. (leave slot 2 empty)

if its boots up , the shut it down again and install on slot 2.

this resolved the problem..

这个答案有帮助吗?

得分 0
添加一条评论

I had this problem when replacing 4 OEM 16 sticks with 4 OWC 32 sticks. The machine booted 1x and after that, black screen booth. tl; dr: I solved this by permuting all of the possible combinations of sticks after labelling them 1-4, based on that 1x boot order.

I could get things to work with up to 3 sticks (1, 3, 4 and 2, 3, 4), but never (again) all 4. Slot 2 was the most problematic, because I could only get it to boot with certain chips in Slot 2. If I mixed in ANY combination of OEM chips, with Slot 2 always filled by a OEM stick… the machine booted just fine

So, I did a SMC reset and PRAM reset. Didn’t work. Checked that the sticks were flush after re-installing the carrier every time.

After it worked (fleetingly), I assigned each stick a #, 1-4, based on which slot they were in.

So, I called OWC. We agreed that the best way to pursue this was to cycle sticks to see if there was any way to get it to boot. He suggested that I do a return and start over again, but my stubborn ass wouldn’t let it go.

I then hunted around the slots. I started with which sticks would boot when installed in each of the slots. For me, my stick 1 worked in slot 1 and in no other slots. I repeated this for the other sticks, finding that stick 2 worked in slot 3 and four, but never 2. Stick 4 always worked in Slot 2. I used that as my anchor…

Then I checked how the other sticks behaved. I found that I could boot on Stick 1 -> S1, Stick 3 -> S3, and inverse. Stick 2 -> S2, Stick 4 -> S4 never booted again, but Stick 4 -> S2, Stick 2 -> S4 always booted.

Finally, I went with my Stick 1 / Stick 3 pattern, eventually getting a boot (after about 15 seconds) out of the 3, 4,1, 2 pattern.

I have rebooted a bunch of times and completely cycled the power, including disconnecting the power at the wall. I have not done a PRAM reset as of yet. I’ll report back to OWC and here if things get messed up again.

这个答案有帮助吗?

得分 0
添加一条评论

添加你的答案

Truls Zhong Konstali 将永远感激不已
浏览统计数据:

过去的24小时: 32

过去的7天: 225

过去的30天: 952

总计 69,455