Display freezes, fades to white, inverse, then bleeds to bluish

I have a:

MacBook (13-inch, aluminum, late 2008)

model number: A1278

2GHz IC2D

2GB RAM

160GB HD

running 10.5.8

The display will fade to white (almost a corduroy look) then fades more, so that it looks inverted (like a film negative), then fades more so that there is no display except a blueish screen with small vertical blue, purple and black lines - think norther lights. If I wiggle the display assembly just right I can get the display back and fully functional. Sometimes it will hold seemingly indefinitely and other times it will will be okay for a while then fade again.

I've read about symptoms like this in other threads and forums, but can't remember the cause and can't seem to find them. My memory (which fades too) tells me it's either the data display cable (or connectors) or the inverter. Both of which it seem would be a bit of a pain in the keester to replace with these new displays with class across the front and no bezel.

Also, display works on a second monitor.

any ideas?

lemerise?

已回答! View the answer 我也有这个问题

这是一个好问题吗?

按维修分数 1

评论:

yes, it's had a liquid spill. I'll check the data display cable connector.

添加一条评论

GIVE TOOLS. FIX FOREVER.

GIVE TOOLS.

FIX FOREVER.

Spread the Fixmas cheer.

GIVE TOOLS. FIX FOREVER.

Spread the Fixmas cheer.

4个回答

已选择的解决方案

Sounds like the display data cable to me not an inverter problem. Check the connector on the logic board first and see if the catch is still in place. Move the display and see if it's moving the connector to the logic board. It could be damaged where it passes through the hinge or could be the connector to the LCD. You'll have to play with it to see which.

这个答案有帮助吗?

按维修分数 3

评论:

+ It is either going to be the LVDS/video cable or the connector for it on the logic board. I have seen several post here on iFixit with compromised LVDS sockets/headers for this ERA of MBP. It appears they didn't get them soldered down well.

添加一条评论

I have the exact same issue with a 2008 13" 2.4ghz Macbook aluminum. It is working with an external monitor attached. Sometimes I can power it on and the display will work for 2 seconds or 2 hours. Mine began with a small water spill but I immediately tilted the laptop upside down to ensure no water got in. (but then again maybe some did)Apple store representative quoted me $700 to fix it but I wasn't so sure the guy new much about it. I keep reading about Inverter boards and cables going bad with the symptoms that my computer is having. Is the problem fixable? Please help... Thanks

这个答案有帮助吗?

按维修分数 1
添加一条评论

You should try cleaning the display cable at both ends. Because if it the inverter you'll have to replace led screen do that it's built in to the screen. Q. Has the MB had any type of a liquid spill?

Hope that help. Good luck with that.

这个答案有帮助吗?

按维修分数 0
添加一条评论

Use your right finger to pull the screen right top edge towards you and use left finger and push the left top edge further from you.

Do not over pull or push.

Perform this a couple of times and it has solve my problem permanently.

If it does not work, do the other way around. Right edge further from you and left edge towards you.

My display is slowly fading to white. Why?

这个答案有帮助吗?

按维修分数 0
添加一条评论

添加你的答案

hdh607 将永远感激不已
浏览统计数据:

过去的24小时: 1

过去的7天: 8

过去的30天: 50

总计 6,000