跳转到主内容
帮助

当前版本: rj713, oldturkey03, pollytintop, ABCellars, and Brian (投票详情) ,

标题:

Display freezes, fades to white, inverse, then bleeds to bluish

文本:

I have a:

MacBook (13-inch, aluminum, late 2008)

model number: A1278

2GHz IC2D

2GB RAM

160GB HD

running 10.5.8

The display will fade to white (almost a corduroy look) then fades more, so that it looks inverted (like a film negative), then fades more so that there is no display except a blueish screen with small vertical blue, purple and black lines - think norther lights. If I wiggle the display assembly just right I can get the display back and fully functional. Sometimes it will hold seemingly indefinitely and other times it will will be okay for a while then fade again.

I've read about symptoms like this in other threads and forums, but can't remember the cause and can't seem to find them. My memory (which fades too) tells me it's either the data display cable (or connectors) or the inverter. Both of which it seem would be a bit of a pain in the keester to replace with these new displays with class across the front and no bezel.

Also, display works on a second monitor.

any ideas?

lemerise?

设备:

MacBook Unibody Model A1278

状态:

open

已接受的回答:

55806

原帖由: hdh607 ,

标题:

Display freezes, fades to white, inverse, then bleeds to bluish

文本:

I have a:

MacBook (13-inch, aluminum, late 2008)

model number: A1278

2GHz IC2D

2GB RAM

160GB HD

running 10.5.8

The display will fade to white (almost a corduroy look) then fades more, so that it looks inverted (like a film negative), then fades more so that there is no display except a blueish screen with small vertical blue, purple and black lines - think norther lights. If I wiggle the display assembly just right I can get the display back and fully functional. Sometimes it will hold seemingly indefinitely and other times it will will be okay for a while then fade again.

I've read about symptoms like this in other threads and forums, but can't remember the cause and can't seem to find them. My memory (which fades too) tells me it's either the data display cable (or connectors) or the inverter. Both of which it seem would be a bit of a pain in the keester to replace with these new displays with class across the front and no bezel.

Also, display works on a second monitor.

any ideas?

lemerise?

设备:

MacBook Unibody Model A1278

状态:

open