跳转到主内容

13" aluminum unibody, 2.0 or 2.4 GHz Core 2 Duo processor.

632 个问题 查看全部

Battery Indicator Button Not Working

Hi there!

The battery indicator button doesn't seem to be working. It lights up when I connect the charger, but the lights doesn't come on when I press the button. I recently swapped out my old battery (which couldn't even hold a charge for 3 minutes!) with a Newertech, so it's not the battery. Also, seeing as it lights up when charger is connected, it's not the logic board connector. I have reset SMC and PRAM several times and it doesn't do anything. As far as I've researched, it might be the foam surrounding the button, but I'm also looking for alternative answers as to why it's malfunctioning. If the button itself turns out to be broken, is there a way to buy a new battery indicator?

Please and thank you's!

Update (02/24/2016)

I opened it up and found that everything was in working order. It seems to me that it is the button itself that isn't working, whilst the LED's work as they should. I'm attaching a picture of the unit, if that could be of any help at all.

http://i.imgur.com/bfVUI2t.jpg

已回答! View the answer 我也有这个问题

这是一个好问题吗?

按维修分数 0
添加一条评论

PC 笔记本电池

An easy fix for a big power boost.

现在开始购物

PC 笔记本电池

An easy fix for a big power boost.

现在开始购物

4个回答

已选择的解决方案

It is clear that just the button itself is malfunctioning.

I would spray it with contact spray or dab it with 90%+ IPA and see if it works, just in case it was due to grime.

If not, it needs replacing but some of those button assemblies are welded - not sure about your model - and once they are removed, can't be glued back in place.

So you need to be very careful when replacing it (if doable) and not pry anything off or screw too tight.

EDIT/UPDATE:

@henchr

Since I looked at the new picture I can tell you your problem right away: the button / micro-switch itself is missing.

Underneath the silver button there should be a rubber gasket. Underneath that gasket a button attached to the circle showing in your picture. Where's that button?

I guess it's broken off, and like you have to replace the battery indicator flat cable assembly. Like @alinorne (Kevin) said, it shouldn't be expensive to come by and a pretty easy fix.

Second, what I mean by fragile: the plate is screwed onto the side of the computer through 3 screws that go into 3 screw brackets. Those screw brackets are welded onto the the side frame. If they break off (don't over tighten your screws!!!!), they're a pain to put back - if feasible. I have yet to find a satisfying way to glue them back. If someone can share a good way I'll be thankful.

这个答案有帮助吗?

按维修分数 3

评论:

I'll use a tiny amount of WD40 on a Q-tip and see if I can get any grime off that way. As you can see in the picture I attached in the update, it's not grimy (not especially fragile), but there might be some grime lodged around the contacts. If not, I'll just search around and see if I can find a new button.

添加一条评论
最有帮助的答案

Let's take an in depth look at the battery. Please download and run Coconut Battery and let us know your results.

http://www.coconut-flavour.com/coconutba...

这个答案有帮助吗?

按维修分数 4

评论:

The battery is in pristine condition. The problem has been around since before I changed out the battery. But here's the results: http://i.imgur.com/7SNuhhk.png

Is the lip of the battery test button possibly depressed and caught under the frame?

添加一条评论

That battery indicator is not that expensive, I recommend purchasing one on eBay and installing it. Make sure it comes with the housing on the button as well :-)

这个答案有帮助吗?

按维修分数 3
添加一条评论

It seems that you have some dirt on the pins of the chip.

Disconnect it take some alcohol and toothbrush. Gently clean pins and dry it with fan. Hopefully it helps.

这个答案有帮助吗?

按维修分数 0
添加一条评论

添加你的答案

Henning Klepp Christensen 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 4

过去的30天: 14

总计 291