跳转到主内容

修复你的物品

维修的权力

商店

2.26 or 2.4 GHz / White plastic unibody enclosure

765 个问题 查看全部

No sound. Speaker wire disconected.

I recently had to open up my Unibody A1342 due to water spillage.

As I was following your teardown, at step 10 I seemed to miss something. Whilst trying to gently pop off the speaker wire connector I must have used too much force and it just snapped off. I cannot see any way to simply click it back in, does it need soldering? There doesn't seem to be much metal to solder together, is there another option? Would hot glue work?

Block Image

Update

Block Image

You can see the damage here

Block Image

And here.

I have since seen other instructions of what I should have done, gently prise the connector away. However, now that the damage is done is there anything i can do. I don't have any experiece with soldering.

Any advice greatly appreciated.

Thanks all.

已回答! 显示答案 我也有这个问题

这是一个好问题吗?

得分 1

评论:

Sai G, post some images of your connector and the damage with your question. Using glue for a lasting repair is usually not an option.

完成的

Thanks for reply oldturkey03

I will post a photo as an answer as i can't see a way to do it here.

完成的

Use this guide to add images to an existing question 在已经存在的问题里加入图片

完成的

Got it

完成的

添加一条评论

1个回答

已选择的解决方案

Sai G, the only proper way of fixing this is by soldering. You can either solder the connector back on the board, the solder pads seem to be intact. Or you could solder the wires straight to the board. Either way, it will have to be soldered. Consider having somebody else do that for you if you have not soldered before. Glue will not work:-) don't try it

这个答案有帮助吗?

得分 2

评论:

Thanks, I'll try to find someone.

完成的

Found a dude in an old electronics shop, he managed to solder the connector on, only charged me €10. Now sounds OK again.

完成的

添加一条评论

添加你的答案

Sai G 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 0

过去的30天: 2

总计 115