跳转到主内容

A 35mm FD-mount single-lens reflex camera introduced in April 1984 as the second in Canon's T series.

9 个问题 查看全部

Attempting to take a shot, but buzzes, followed by beeping.

Just picked up a Canon T70 from a thrift store, and wanted to test it out. When I initially checked to see if it would take shots, it just buzzed. After the buzzing finished, the camera would beep repeatedly.

The battery level appears to be fine, although I have not had the chance to replace them. Looking online, I heard that it could be that the motor has seized up.

Does anyone have any experience opening up one of these cameras and adjusting/lubing the gears? Any tips?

回答此问题 我也有这个问题

这是一个好问题吗?

得分 2
添加一条评论

2个答案

Same problem you find answer?

这个答案有帮助吗?

得分 0
添加一条评论

Have a working one. After a long time in storage, motor sounded like it was agonizing to advance the film, but after 2-3 rolls of films it went back to the happy sound I remembered from its youth. So motor seizing up could be an issue.

I also have another T70 I just got for future use as spares, same problem as nuget48. I downloaded the service manual (google for it, its freely available) that shows how to get to the motor. I will first try to move things from the outside - nudge the rubber take up reel to see if I can free anything, and if its not helpful will try to get to the motor when I have some free time, I will let you know if the problem was solved.

Another thought: since the shutter did not operate as well, it could be stuck on that. maybe I should first check the shutter.

anyway I will have something to play with :-)

这个答案有帮助吗?

得分 0
添加一条评论

添加你的答案

nuget48 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 2

过去的30天: 35

总计 2,170