The IBM ThinkPad T43 was released in February 2005. The ThinkPad was designed and developed by IBM from 1992-2005, then by Lenovo from 2005-present. This page includes repair information, troubleshooting, background, and additional information.

2 个问题 查看全部

T43p will not POST

Hello. I have (found) a T43p.

It came with a 2878 dock and a battery. I am unable to find a charger that fits the 2878 dock but is able to find one that fits the laptop itself. The battery is able to be charged by the device (the battery LED was amber then it turned green), and when unplugged you can hear the coil whine of the battery/motherboard circuit. However, no matter what I do the machine will not turn on (the power LED will not come on)

And thus I took apart, cleaned and reassembled every part. The symptoms remain, so I probably didnt made it worse.

Note that my unit come with a fingerprint sensor, and that the hard-drive is missing. However, I do not think either of these will prevent the machine from powering up and post. I put a Win NT workstation disk in, just in case.

It come with two stick of Hynix DDR2 memory, but then, again, this should not prevent it from powering up.

The machine come with a full set of Centrino (north, south, CPU, wireless), and I think it is the 900 Series Sonoma Pentium M Dothan “variant”. It also come with AMD ATi FireGL Mobile.

已回答! 显示答案 我也有这个问题


得分 0

(accidentally touched the black wireless antenna against an area between FireGL and southBridge)

Woah woah woah. I get fan spin. Drive is beeping. Display is black, though. And no power beep, either.

… hm.

Maybe it just came online after charging itself for a while longer. I tried touching the antenna after powering it down. Doesn’t seem to do anything.

Well, one step closer to booting.


Hm. Let's try power up and listen to the power beep.

(two short beep: 1. System board. 2. DIMM.)


Wait. If I put this disk in the beep is different.

(One long and two short beeps, and a blank or unreadable screen: 1. System Board. 2. LCD assembly. 3. DIMM.)

Thats not good either.. Let's try plugging in the palmrest assembly and having the CD in.

.. yeah. one short beep, wait a while, and another short beep followed by another one spaced apart.






Hm. So I have this amber light, as I had before.

Now I need to remove the palmrest to get access to the antennas, which means I need the screwdriver. Which is located … hm. oh here.

(twirling screws)

Hm. Then I scrape the antenna around … here? (nothing happens)

What if I move it to (move it to bridge a nearby SOT23 and a capacitor) oof. That was a spark. Oh the battery LED had gone. That’s bad. (detached power and motherboard) looks fine. (smells) Doesn’t seem to have burnt anything yet. Let’s try plugging it in again. (plugs in, waits impatiently) oh now the amber light. oh now the green — it flickered. not excellent. So what if I put back the keyboard and try turn it on?

(LED bar carasols) ooo. We have things. Wow ooo the display came up!

Wow! **** ***** wow power beeps and everything.

Okok. so let’s turn this off now. (presses power button) can you turn off? (screen goes black, power led stays on) hello?

(machine beeps loudly before turning off) oh, you just get to wait.

Now let’s type up all this stuff and take pictures.

(hits power button) Hmm. now it don’t want to. Comeon. I don’t want to reset this every time I start this. But at least I can look at the post code.

Can I do this without a powered board? (detaches power and tried antenna manuever. nope. (plugs things back in and fiddles with antenna joint)

woah! that’s a big spark. hopefully i didnt kill anything. probably worth probing to see whats actually going on.

(plugs in) hm the charging led turned on. its green, tho. so that wont help.

(tries to look up datasheet) Oh, and you thought NOW it’s a perfect time to turn yourself on?! Battery, too.

(hurriedly put it somewhere secure and plug it in and take picture of splash screen)

Block Image

(presses power button) uh … can you do something? I pressed “access ibm”, but … hm. it appears to be frozen. hello? (press and hold power switch before pressing to turn it back on) Ok. now it will start, but the screen is black. At least we have a picture of the splash before .. well, since now it’s half-dead again why dont we look into the chips?

As for the bezel, well, I intentionally removed it because … well, to be fair I could put it back now. I was thinking that the display won’t be dry enough since I showered basically everything with water to clean them (before drying them off by blowing at them a space heater for 8 hours). I know this isn’t a good way of cleaning, but it cleans them well and leaves the least amount of .. stuff behind. I even rinsed the main board with distilled water (before drying) to make sure.

(observes PCB trace)

uh …oh it goes to the south bridge directly. Oof that’s not too good.

(trying to get the probe onto the two points I bridged and MIGHT have accidentally swiped across something)

oh it powers up again. Huh. (probes) 3.18V that doesn’t sound too bad.

(touched south brodge chip by hand) oo that’s warm. we might have a bad south bridge.

(turns machine off) Hm.

(looking up chip number)

huh it powered on by itself again. but this time I touched absolutely nothing.

Hm. Maybe we will let it sit like this. But boy is the north bridge hot.

(looks around)

yeah i might try removing that bottom ram. And then we will just let it sit there, I guess.

The whole point of this is because the first time the screen turned on (before I started to short things together) it post, and it displayed two error codes, and I went into BIOS Setup. And more annoying is because I didnt take a picture of that error code screen. However as I described, immediately powering it down (and powering back up) and I am greeted with a black screen instead. I understand there must be patience but … I don’t think this is about being patient. there is definitely something wrong with it.

(gently pressing finger on the suspecious chips near the south bridge)

oh, it came up.

(waits patiently) The Superbay Ultrabay LED lit up. That seems like a welcoming change.

(stares blankly while listening to the fan rattle) I hope i didn’t kill the south bridge.


得分 1


Well, at least I know that our school have at least one more T43p (series) that is in working condition. That's slightly comforting.

The other laptop I .. yeah. it probably isnt compatible anyway.



The bottom RAM slot on the T43 and a few others is known to have issues. Take the lower module out (not the one under the keyboard) and see if it POSTS — if it does, bad SODIMM slot.

It can be repaired with a known good replacement board, or if you can reflow the solder on the pins that is also known to fix the issue. I know this isn’t what you wanted to hear, but a lot of “as-is” T42/T43 machines are due to this exact issue.


得分 2


I did reseat the RAM and it beeped once, read the disk and continued. However the display is dead like anything. I might try and seek out another top panel unit or use a external one. But so far it is stable.

This machine also come with two 512MB of RAM, so it still should work.

A bad sodimm slot dont make a computer total trash, right?


@cdr_xavier If it boots with one module under the keyboard and not the lower, the motherboard is bad 100% of the time. As far as killing it, ehh yes and no. Yes, it DOES mean you're selling "as-is" to cover your rear end, but no it doesn't hamper it since you just use a large DDR2 module under the keyboard. I wouldn't touch a machine from this era with a suspect/known bad board personally, but some people don't mind.

You may be able to reflow it, but it's not always a stable fix. That said it's worth trying, as most of these are Intel GMA, and not AMD for video.

You found it for a reason -- most people shy away from "known bad" ones.



It was "found" partially because it is docked to the dock (that required a key to unlock), and I am only able to part the two by partially disassembling the dock and pry open the bottom to actuate the release mechanism, before rebuilding the dock and disable the lock (by removing all the lock pins).

Then it have a near-dead battery that messes with the laptop's circuitry. (or vice versa). It is in fact "stuck" in this non-powered state just now again, but I am able to get the battery light to show amber, so it could fire up any second.

Then it has received a nasty physical shock (at one of the corners, visible damage with broken plastic bits and stuff) that probably took the HDD with it. The only reason I picked it up is because I know that because the dock is still attached to it, the person putting it in (the tech dump) is unable to detach it, which means that that person (or the persons that the person can go to) cannot open up the laptop and possibly fix it.


@cdr_xavier That potenially explains the death of the SODIMM slot, especially if the symptoms line up. Shock doesn't help.




Xavier Jiang 将永远感激不已

过去 24 小时: 1

过去 7 天: 3

过去 30 天: 7

总计 375