Model A1138 / 1440x960 screen resolution

100 个问题 查看全部

What does the message "invalid memory access" mean?

I was given this powerbook G4 model A1138, which doesn't start up beyond the apple screen. When I tried to use the apple hardware test disk, I received the message, "invalid memory access at srr0:0002c2d4 srr1:00003030". Then there is info on the machine, Apple PowerBook5,8 4.9.6f0 boot rom build on 10/05/05. Welcome to open Firmware, system time and date is 01/01/1904 00:01:20. There is then the choice to type "mac-boot" or "shut down". Typing "mac-boot" will get me back to the apple screen again and no farther, "shut down" works just fine. Also the little timer under the apple will stop after a few minutes and the optical drive will too and then the screen appears frozen/stuck.

I have tried to use a (new) OS X 10.4 install disk and only get the same results. However when holding down the option key at start up, I get a blue screen with an icon of the hard drive and the install disk and both icons have a small x on them, what does that mean? When using the hardware test disk, only the hard drive icon has the x.

Where do I start looking for the problem for this mac? Hard drive?

已回答! View the answer 我也有这个问题


按维修分数 3


Unfortunately I have no history on this machine except mine so far.

Tried your tip Mayer, with the RAM, same results as before. Will try without airport card plugged in next.

Will get back to you in a couple of hours, nap time, got radiation this morning and feeling punky

While you were napping, I removed the airport card as you suggested and the problem still persists.


所有超过US$100或包含 Pro Tech工具包的订单免费送货!




Solved my problem with a new hard drive and the retail os x 10.4 install dvd by using target mode and my iBook to remote install. After the install, software update ran and updated my os to 10.4.11 and suddenly all problems have gone away and machine is working. Thanks to all who helped. I never did get an answer to my question, what does "invalid memory access" mean? Now that the machine is working I guess it doesn't matter, still just curious.


按维修分数 2

As strange as this may sound,a loose Airport card can cause this, pull it and see if the problem persists. Also reseat your RAM one at at time and one slot at a time.


按维修分数 7


While waiting for answers, I tried to restart holding the apple+s and got to a black screen that offered the opportunity to repair. typed "/sbin/fsck fy" (this may be incorrect but the string was as indicated on screen) and came up with a diagnoisis that "volume library laptop could not be repaired". does this help any?

To repair your hard drive you first need free it up (unmount it). Do this by starting up from your system installation disk "C" key. Go to the second screen pull down menu to Utilities > Disk utility. Select your hard drive in the left hand column. Run repair on it till it runs clear, then repair the permissions. This probably has nothing to do with the other problem so fix memory problem first.

It won't go that far. just the apple screen with the continuous timer, until it stops. Seems the only screen I can get to other than that is the black text screen and I don't know how to tell it what I want it to do through command lines.

You need to get it boot first. Disconnect the hard drive and see if you can boot from the system installation disk. Also tell me about the system disk you are using

System disk is a retail os x 10.4, the black disk with the silver X and it says "MAC OS X Tiger, includes Xcode 2, install DVD, version 10.4, 2Z691-5305-A". I have tried it in my iBook and the disk functions properly I believe. I will give it a try right now, without the hard drive, and see what happens. Get back to you as soon as I do. Also the hard drive doesn't get "seen" by my iBook when I have it on the ide/usb adapter and plugged into the iBook usb ports. Ports work with other items though. (just an aside)



Hi . i cant fix this &&^& !!!!!! how to fix it???? pls answer me ..Thankx..


按维修分数 0


pecostx51 将永远感激不已

过去的24小时: 2

过去的7天: 10

过去的30天: 68

总计 10,349