No video after SSD upgrade, 2 LEDs on, 3rd off

After the initial replacement, the system worked and I was able to use it as normal. A couple of days later, the screen went black while I was using it, and have not been able to get any picture since. I took it all back apart, and have broken it down to having the least possible things connected with no difference.

When plugged in, I get LED 1. After pressing power, LED 2 lights up. I never get LED 3. Fan spins up when powered on, eventually running at max.

I’ve tried new PSU, new CPU, and new logic board with no success. I’ve also tried combinations of all of the new and old parts together without any difference. I must be missing something. Is there a ‘reset’ or something that I might be missing?

回答此问题 我也有这个问题


得分 0


Diagnostic LED - what order?

Share a Picture of the motherboard connection and the end of the flex cable of the LCD.


I'm 99.9% sure it isn't the cable, because I've used two different cables on both logic boards. I'll get a picture, though.

As for the link - the board has 5 LEDs, not 4, and it doesn't make sense for me to be looking at it backwards, because 1 is always on when the power is connected, so thats obviously LED 1. There aren't any situations where LED 4 or 5 would be on with LED 1 off.