跳转到主内容

Model A1312 / Mid 2010 / 3.2 GHz Core i3 or 2.8 & 3.6 GHz Core i5 or 2.93 GHz Core i7, ID iMac11,3

396 个问题 查看全部

iMac shows a distorted blank/rainbow pixel screen after turning it on

iMac works when I press the shift key during start up, which then opens in Safe mode, but during a normal startup, after the apple logo disappears and leads to the login page, instead of the log-in page, a half blank white screen, with rainbow pixels distort half of the blank screen. The iMac works as expected during safe mode as the login page appears, seems normal as well as the desktop after login.

已回答! 显示答案 我也有这个问题

这是一个好问题吗?

得分 2

评论:

Can you give us your exact model so we can guide you to the correct guide and needed part.

Look at the bottom of your systems foot stand to find the serial number and plug it into here: EveryMac - Lookup then paste your systems URL here for us to see.

完成的

添加一条评论

2个回答

已选择的解决方案

Does the last four characters of the serial number contain one of the following groups (for example, xxxxxxxxDHJQ):

DHJQ, DHJW, DL8Q, DNGH, DNJ9, or DMW8

DPM1, DPM2, DPNV, DNY0, DRVP, DY6F, F610

The serial number can be found on the bottom of the stand or under "about this Mac".

这个答案有帮助吗?

得分 1

评论:

Btw, I have posted a pic of my screen here: https://imgur.com/HokjRey

完成的

raven, I have not seen that type of pattern before. Hook it up to an external monitor and let us know what you get.

完成的

Thanks @mayer I will give that a shot and report back.

完成的

Hi @mayer, when I plug in an external monitor, the iMac still freezes before the login screen, but instead of a fuzzy screen with a rainbow of random color pixels, there is just a uniform blue screen (on both monitors). Any advice on what to do or suggestions on what the diagnosis could be? Thanks in advance

完成的

Try booting in Safe Mode by holding down the Shift key on start up and see if there are ant changes. Next try holding down the option key and booting from the repair partition.

完成的

显示更多的4条评论

添加一条评论
最有帮助的答案

Sadly, your GPU boards VRAM has problems.

When you go into Safe Mode you are using the low resolution mode of the GPU which uses shared RAM. When you normally startup the system starts off in low res then switches into normal mode leveraging the GPU's VRAM.

这个答案有帮助吗?

得分 3

评论:

Is this type of issue able to be fixed?

完成的

Can you give us your model info as it depends on what you have.

完成的

Hi Dan, it is a 27 inch LED-LCD iMac (Aluminum Unibody) bought in 2010 (this model was released in 2009 and discontinued in 2012)

完成的

@samneedshelp - Sam that still covers over 30 different models.

We're guessing here you have the Mid 2010 model. To be sure click on the blue link I posted under you question and plug in your systems S/N.

完成的

Hi @danj I am having a similar problem to what Sam reported. My iMac is an A1311 (EMC 2389) -- mid-2010 with 21.5" screen. Can you offer any tips on how to solve this issue? (Or whether it is solvable in the first place?)

完成的

显示更多的3条评论

添加一条评论

添加你的答案

Sam 将永远感激不已
浏览统计数据:

过去的24小时: 5

过去的7天: 17

过去的30天: 73

总计 10,432