跳转到主内容

The first Legacy was available at Japanese dealerships on February 1, 1989, with worldwide distribution starting in 1990.

14 个问题 查看全部

93 Legacy non-turbo engine turns over but no spark, injectors working

engine turns over but no spark, injectors working which rules out the crank sensor, coil metered within limits. was going to change control module as it is of the rare few the auto parts stores cannot test. not sure what the camshaft sensor does when it goes bad? not sure of other problems it could be?? would appreciate some accurate diagnosis on the problem. thanks

已回答! 显示答案 我也有这个问题

这是一个好问题吗?

得分 0
添加一条评论

1个答案

已选择的解决方案

currinmarco , Have you scanned/retrieved any trouble codes as this would be the first step to try and pin point the fault. If you could, some of the auto parts suppliers offer free code reading like Pepboys, Nappa, Advanced auto parts,etc and some of the guys are very knowledgeable and may have seen the issue often and put you on the right track. One quick check coolant temp sensor to make sure it is plugged in, sits under plenum could cause no start condition. Posted some trouble shooting links for you to checkout below. Good luck.

I hope this helped you out, if so let me know by pressing the helpful button.

http://www.aa1car.com/library/no_spark.h...

http://www.ultimatesubaru.org/forum/topi...

https://www.youtube.com/watch?v=YBE7c7lf...

http://www.troublecodes.net/subaru/

这个答案有帮助吗?

得分 1
添加一条评论

添加你的答案

currinmarco 将永远感激不已
浏览统计数据:

过去 24 小时: 0

过去 7 天: 1

过去 30 天: 14

总计 230