跳转到主内容

修复你的物品

维修的权力

商店

Nikon's D3200 DSLR has 24.2 megapixels. This model is geared towards casual photography enthusiasts with advanced specifications and performance.

62 个问题 查看全部

The auto focus doesn't work

The auto focus on the camera is broken. When the lens is switched onto Auto, the camera doesn't take pictures at all, and on manual it needs to be focused manually (obviously). I'm not sure if it's a setting that I can fix or if there is something wrong with the camera itself.

已回答! View the answer 我也有这个问题

这是一个好问题吗?

得分 9

评论:

After reading this I took the lens at the end and "tweaked"it back and forth, BOOM then autofocus started working. Must have been jammed or something! Thanks for the post

完成的

The camera will only focus when I put the dial on GUIDE. Any other button on the dial will not focus even though it will take pictures.

完成的

I had the same problem. After reading Mark Fouts comment I tried his solution and it solved it. It was slow to auto focus but it's getting better the more I work with it now.

完成的

Don’t panic.... it is not necessarily a problem with the camera OR THE LENS! I encountered the same problem but found out that the D3200 requires a AF-S lens to be able to auto focus. You can find many of these for a reasonable price on EBay or the London Camera Exchange.

完成的

I had problems with my autofocus on my Nikon D700. Sometimes it worked sometimes it wouldn't focus at all. I was afraid I needed to get it fixed by Nikon. But by inspecting my AF sensors (place your mirror in Mirror up postion (Mup)and release the shutter) I found out that there was a little piece of foam stuck right in front of the AF sensor. I carefully removed it with a toothpick and Voila the autofocus works perfectly again. Sometimes big problems have simple solutions.

完成的

显示更多的8条评论

添加一条评论

14个回答

已选择的解决方案

The problem might be with the camera body, the lens, or the interface between the two.

In case it's the latter, the following might be a quick fix:

Detach / reattach the lens: turn off the camera, depress the lens release button and rotate the lens clockwise until it detaches. Then reattach the lens by inserting it and rotating counter-clockwise until it locks. You may repeat this a few times.

Turn the camera on and check if the problem persists.

If so, you can try cleaning the contacts that connect the lens to the camera body: detach the lens completely, and look at the rear flange of the lens to locate the contacts. Wipe the contacts carefully with a pencil eraser. Be careful to avoid debris getting into the rear of the lens. Then look at the lens flange on the camera body to locate the lens contacts' counterparts, and wipe these with the pencil eraser as well. Again, be careful not to get any debris inside the camera. Reattach the lens, turn the camera on and check if the problem persists.

If the above did not solve the problem, you'd have to figure out if the problem is with the camera or the lens. The easiest way to do this is to try a different lens. If you don't have one, see if you can borrow one from a fellow Nikon owner. The lens does not have to be identical to the lens that came with your camera, any recent Nikon AF-S type lens will do. If autofocus works with the other lens, the the problem is almost certainly with your lens.

In case the lens is a cheap kit lens like the AF-S DX 18-55, it is likely not worth the trouble to repair, since such a lens can be bought new for about 100 bucks - or you might take the opportunity to upgrade to a better quality lens.

If autofocus does not work even with a different lens, there's no easy fix - the problem is almost certainly with the camera body. There are (as far as I know) no menu settings that inhibit autofocus from working correctly. However, consider the following: If you're using LiveView (that is, you use the camera's LCD display rather than the optical viewfinder for composing your shots) autofocus will always be slower and less precise compared to using the viewfinder, and depending on conditions the camera might not be able to focus correctly.

这个答案有帮助吗?

得分 8

评论:

You forgot to mention the back button focus - if you are using it then the shutter release button will not automatically focus. Try to take a photo with the back button focus.

完成的

And also try another lens to see if that one works. That will eliminate the body as the issue or part of the issue.

完成的

My auto focus was working. It seem to be doing the job right. But for some reason.. the Manual would not move. The problem was on the lens it self. Nikkor 55-200 af-s/ed/vr. I played with the focus ring. Forcing it back an forward many times trying my luck with brute force.... But to no avail. I knew there was something else I could do.. I really wanted my Manual focus ring to be in optimal condition to shoot videos with my D3100.. After thinking and reading more common problems that users are having.. it seemed to me. That the function on my A/M switch that was not doing it's job . So once again. I tried my luck an opened the switch casing by removing the single screw located on the lower part of the panel. Just to take a view. And while I.. was there I moved the A/M switch.. it looks like a barrel with a spring around it..gently.. and moved the connections applying some pressure to assure that there was nothing loosed.. as Soon as I moved the barrel. It released the focus ring. And that did it! Thank you.

完成的

you saved my life!

love you man!

完成的

添加一条评论

I had the same issue and was able to fix it by slightly and gently turning the focus while in auto focus. It's like something was gummed up inside or it wasn't quite right on with the gears, but after I turned it slightly it would jump into focus. Now it works fine, without my assistance. For how long is yet to be determined...

这个答案有帮助吗?

得分 5

评论:

For days I had tried all the solutions mentioned in the comments. I held the button down half way to start the auto focus and then used my hand to force turn the lens back and forth and suddenly the auto focus feature started working again! I have had no issues since. Previously I had reformatted the memory card and defaulted all the setting in the camera.

完成的

same here, for the last week i've been trying everything posted on the internet ! I even teared the camera apart looking for a problem, so funny the solution was so simple ... hhhhh

what I did was simply wiggling the nob 1/4 way and HORRY ! it started working again

Thanks bud

完成的

I did what Michael S suggested and it worked! Thanks to you Michael

完成的

Guys. First of all check if the focus of the lens is set to AUTO or MANUAL. The button is on the lens itself.

That's the first check

完成的

I had exactly the same issues, and actually gave up on the camera for a while, until I found Michael Silvers answer on this site. I did exactly as he had done, and now I have my Auto Focus back, so a big thank you from me Michael.

完成的

显示更多的2条评论

添加一条评论

I had the same problem and it turned out that I had set the AE button to AF on. I did not know that this negated the half press focus function of the shutter button. Have switched back to default mode since the autofocus function is much quicker and crisper that way.

这个答案有帮助吗?

得分 5

评论:

I had almost given up and then I found your post!! It worked perfectly! Thank you SO MUCH!!!

完成的

I was about to send my camera in after searching YouTube and google for a few hours, reseting camera, cleaning sensors. THANK YOU! This worked!!

完成的

添加一条评论

Ok so I fumbled around with my camera for like an hour -_- only to find that the switch on the lense one for A and one for M was the problem. I had it on M for manual when it should have been on A for auto. My auto focus now works wonderfully.

这个答案有帮助吗?

得分 2

评论:

This maneuver solved the problem <3

完成的

添加一条评论

similar difficulty. my d3200 already has that nasty 'metering error, send to nikon' message, but was using it on manual with no problems.

then bought a new vr/af/dx lens and suddenly had all the features of that lens the with the knob on manual setting,

BUT, only after drilling down into the setup menu. one of the metering settings was set to auto aperture. i set it to 'manual' and was shocked when the lens started auto focusing, vibration reduction and got some excellent images.

twiddling the ISO auto, minimum shutter speed and other options also allowed improvements. it seems there's more to this error than just a simple mechanical issue

this camera has the old/original software version, but i don't want to upgrade until i figure out what actually is causing the metering error.

if anyone gets hold of a repair manual for these, PLEASE share it!

nikon does release lens repair manuals, but who need them, they are a real nightmare to fix!

这个答案有帮助吗?

得分 2

评论:

Same problem, my D3200 would not autofocus on ONE lens. I was sure the ens was broken because I could hear it try. It just whirred. It aso made the viewfinder jump 3 times when I first put it on. However, it could be manually focused. After reading this forum, I put it back on A and forced it to focus. It was stiff and made a ratcheting sound that sounded bad. But it started working. Huzzah and thank you for posting!

完成的

添加一条评论

Had the same problem, my pictures were blurry because the lens could not rotate automatically, instead it produced some sound meaning something was not working well.I removed the lens and fitted it back and switched the lens to A mode. After that its now working perfectly. Thanks.Make sure you comment after facing a challenge, you will help a brother somewhere and make the universe better.

这个答案有帮助吗?

得分 1
添加一条评论

Same problem with failure to focus - solved by ensuring switch on lens was set at A not M - simply really !

这个答案有帮助吗?

得分 1
添加一条评论

I had the same problem last Sunday ( Sept 24, 2017) I had Nikon D5300 and the AF-P 18-55 lens suddenly stopped auto focusing. I have tried several methods as suggested above but t was still not working. I have tried a different lens and the auto focus is perfect. Hence, I am now confirmed that there is some issue with the lens. When I am changing the setting to manual the shutter is firing but still there is focus issues.

I am still struggling . Someone plese help?

这个答案有帮助吗?

得分 0

评论:

Exact same problem with my Nikon d5300 with afp 18-55mm kit lens! It wouldnt autofocus. I cant even use manual focus. Anybody found a fix?

完成的

Did u get any solution?

完成的

I am facing same issue since last week, if u both get any solution, plz let me know.

完成的

添加一条评论

I was having this issue for MONTHS with the standard lens and a new lens. I finally reset the shooting menu and it magically worked. I feel dumb for not trying it sooner, but I’m very happy now.

这个答案有帮助吗?

得分 0

评论:

How did you reset the shooting menu?

完成的

添加一条评论

Same here. After tinkering for a while I realized I had messed with the settings while on M mode and focused on the background. Then i inadvertently switched back to A mode and the pictures wouldn't focus on the foreground because i needed to go back to M mode to switch focus to the foreground. Hope this helps.

这个答案有帮助吗?

得分 0
添加一条评论

I am having a similar problem. In live video mode when switching the setting to AF-F on my Nikon D3200 it acts like the AF-S setting is supposed to, only focusing when I half press the shutter. It focuses on its own right when I turn the setting on but then stays in that fixed range until I half press the shutter. How do I get it to work correctly and autofocus on its own? Any suggestions?

这个答案有帮助吗?

得分 0

评论:

Update: mine will autofocus itself sometimes and never when I try to focus it on something up close like my hand 6 inches away

完成的

添加一条评论

Initially I tweaked the lens back and forth, as has been suggested, and it worked for a while (temporarily) but I soon discovered that the issue of non Auto focsus was not resolved after all. I too then went into the ‘Menu’ setting, looked for ‘Buttons’, and assigned the AE/AF button to AF-ON. Now all I have to do is depress the AE/AF button to Auto Focus, you will hear the familiar beep sound when your image is focusesd release the AE/AF button once focused and take your picture in th usual way using shutter release - PROBLEM SOLVED. Hope this helps you guys! Admittedly it doesn’t explain why it no longer auto focuses with a slight depression of the shutter release as it used too, for for now at least, I am quite content to have found a work around.

这个答案有帮助吗?

得分 0
添加一条评论

I have this same problem with my Nikon D5300 and lens suddenly stopped auto focusing. I have tried several methods as suggested above but it’s still not working. I have tried a different lens it’s not still working. When i press the shutter button the lens will keep moving back and forth. I don’t know what to do anymore. I have only one camera.

这个答案有帮助吗?

得分 0

评论:

I had the same exact problem (with my Nikon D3200 18-55 3.5-5.6 ), and after searching a lot, watching a lot of youtube useless videos, got the solution reading a lot of the experiences posted here. This is what I did:

I went into the shooting menu and in the first option set all to default.

Same as above, went to the setup menu and reset everything.

Then set the lens on A, forcing the focus manually, I put some force on it going clockwise and back for some seconds.

After restarting the camera the autofocus started to work slow, after some shoots looks like it did some kind of automatic calibration and Voila! working perfectly.

完成的

添加一条评论

I had the same exact problem (with my Nikon D3200 18-55 3.5-5.6 ), and after searching a lot, watching a lot of youtube useless videos, got the solution reading a lot of the experiences posted here. This is what I did:

I went into the shooting menu and in the first option set all to default.

Same as above, went to the setup menu and reset everything.

Then set the lens on A, forcing the focus manually, I put some force on it going clockwise and back for some seconds.

After restarting the camera the autofocus started to work slow, after some shoots looks like it did some kind of automatic calibration and Voila! working perfectly.

Maybe the manual work was the solution, but I wanted to comment also the initial steps that I did. Hopefully this would help someone.

这个答案有帮助吗?

得分 0

评论:

Your solution sounds easy enough but I was not able to find any DEFAULT options in either Shooting or Setup. Can you help me with that on my D3000 please ?

完成的

添加一条评论

添加你的答案

2017Amanda Doris 将永远感激不已
浏览统计数据:

过去的24小时: 33

过去的7天: 256

过去的30天: 1,078

总计 84,537