Early 2011 model, A1278 / 2.3 GHz i5 or 2.7 GHz i7 processor.

731 个问题 查看全部

Liquid damage, temp sensor TPOP -- 124

The computer had water damage, some parts have been replaced. All the Apple resets known to man have been run. Now the fan spins full speed and the Apple hardware test reports 4SNS/1/C0000008: TPOP--124. I've found a few posts of people with the same error. Everyone assumes it's the logic but no one seems to be certain. The issue I have is that the logic board has already been replaced. My next guess is that it's in or near the track pad. Can anyone determine which component is actually failing from the hardware test results? Or point me in the right direction.

已回答! View the answer 我也有这个问题


按维修分数 1


4SNS/1/C0000008: TP0P--124

T= Temperature

P= Power Bus.

*0P= *zero (is not O)

I have the same AHT error code.. any solution?

Did you replace the DC supply Board or the SATA cable?

Any other solution found?

My MBP is A1425 Macbook Pro 13 retina i5 120gb SolidDrive.

Same error 4SNS/1/C0000008: T POP--124


所有超过US$100或包含 Pro Tech工具包的订单免费送货!




I believe it is the temperature sensor on the power supply the number is how far out of spec it is. If you replaced the logic board try a new DC-in board. I'd also notify the vendor for the logic board in case the DC-in board does not fix the problem.

If this answer is acceptable please remember to return and mark it.


按维修分数 2

First heres the best guide on decoding AHT error codes: CNET - How to invoke and interpret the Apple hardware tests. So lets decipher yours here:

4SNS/1/C0000008: T POP--124

  • T 4SNS - System sensor
  • T - Temperature

The next one looks like a multiple

  • P - Power Bus
  • OP - Optical Drive

So what does this all mean? Sorry to say not much ;-{

The problem is you can't depend on AHT alone here. You need to so a little more diagnoses to figure out whats up. Some of your actions also help here in removing possibilities, but only to a point. Water damaged systems can still have issues that one would not think of like wiring harnesses or sensors that didn't get swapped. I think your on the right track looking at the sensors but before you start taking the system a part again lets do a little more testing.

OK what is the next steps here:

I would get a temperature monitoring app installed to see what it tells you. I like Temperature Gauge which you can download from the App Store (others will also work).

The other thing here is running Activity Monitor and look at what process is running. Often this can offer a clue or it could lead to a bad app or malware app that is causing your system to overheat.

Tell us what you see (post a screen capture or two) then we can know for sure what to dig into. Good Luck!


按维修分数 1


The computer has a clean install of OS X, the hard drive has been replaced. But I can't even get through the account setup. So I don't think I'm going to be loading apps yet. I'm assuming due to the other posts about this issue that it's the kernel using 100% of the CPU. I was lucky to even get through an AHT.

Sounds like you have bad SATA or the new HD is bad. What it is sounding like is the indexer process is having problems indexing the files (causing the CPU utilization to spike). Do you have an external HD or flash drive which you can install the OS onto and then using it to boot up your system. See if that makes a difference (it should).

I was able to boot from internet recovery and run AHT. Both produced the same problem. The drive is new.

Need to run it off a different drive (externally) here to isolate the issue. Different volume on the same drive doesn't help. If you can get that far you should then be able to install some temp monitoring software as well as look at Activity Monitor to see what is different running from a clean install Vs. your HD'd OS install. If Activity monitor looks OK on your external drive I think you'll need to replace the HD's SATA cable.


Late reply, but I'm adding this mostly for others finding this via search engines.

I had exactly the same symptoms and same AHT error code with a machine of this model (A1278 i7 2.7) that experienced some water damage (the only other problem caused by this was the death of the SSD). I've been able to temporarily work around it by unplugging the AirPort card (it's the one running from the logic board to the board with the three small round gold antenna connectors).

If you're going to try this, unplug it at the logic board end, and tuck the free end of the cable with the connector behind the logic board so that it doesn't just re-mate with the logic board connector when you put the back case on again.

I'll update here when I've replaced the AirPort card.


按维修分数 0


Whoops, I forgot to comment back on this.

So, with the new AirPort card, the behaviour was the same as with the old card. So, I replaced the AirPort data cable to the logic board. This fixed the problem. I then took a closer look at the original data cable and saw that there was residue from the water ingress on one of the connectors on the cable. After going in and cleaning this up with a cotton bud and some isopropyl alcohol, the old cable then functioned perfectly.



eric 将永远感激不已

过去的24小时: 1

过去的7天: 4

过去的30天: 24

总计 2,285