MacBook Pro带有15寸屏幕的型号

6423 个问题 查看全部

MacBook Pro A1286 not turning on anymore, did 10 sec power on nothing.

I got a Macbook Pro (2008) unibody model A1286 Motherboard 820-2330-A. I do take al precautions knowing how thermal cycles affect the solder joints. So my computer was in such a position that the lid had perfect airflow for the fans. In fact I had all the fans both at 5900rpm. I was running Windows 7 natively.

So I used my macbook plugged in on AC with the removable battery. And honestly i never swtiched it off . But at times when the electricity went off it was the only time the battery drained entirely and turned off.

Now what started happening was that once that happened the lap would not turn on. I searched all over the net and someone at Ifixit said you had to press power button for 10 seconds.. plug magsafe keep pressing it for 10 seconds more.. depress and press again . To my astonishment that made it work.

Now , I never really cared much about that..didn't pay much attention .. thought it would be something that might happen a couple of times.

But now I dissasembled it to clean the heatpipe radiator fins I disconnected the fans vacuumed them and then IT DIDNT" START! I folllowed the exact sam eprocedure as before.

SO what should I do , I managed to get the schematic for my motherboard. I thought about doing a manual SMC reset on the mainboard but the schematics don't tell me the exact location of the SMC reset pad which is 5001. Do you have by any chance the .brd file of this motherboard? Thanks for your help. Some thoughts

- On some places said if the sensor on the heatpipe it's broken it wont turn on (I checked it and it's connected ok)

-I did the 10 seconds procedure on the power on buton.. keep pressing then connected magsafe 10 seconds more .. Nothing ( This worked before) But it worked on the scenario when electricity went off, machine drrained compeltely with removable battery.

then I took battery and did that procedure.

- I managed to check the Power On pins on the logicboard , bridged them .. Nothing!

-I checked the Power button to see might be stuck, disconnected the keyboard flex. found pin 5 bridged it to ground nothing.

-This laptop never exceeded 60 degrees, I had it run windows7 with fans full blast with lubbos at 6000rpm. And was alway on , no thermal cycles. so it wasn';t exposed to vulnerable solder cracks because of thermal cycling.

-I DID FIND ! A SMALL RECHARGABLE BATTERY ON THE LOGIC BOARD which was in bad condition like as mall button cell which was soldered and said F8430 on top. i'm thinking this might be the reason some times the other procecure worked but I don't know what voltage this button cell is

Picture for the button cell is on this link

I'm hoping you can help me out, I'm really sad

已回答! View the answer 我也有这个问题


按维修分数 1

所有超过US$100.00或包含 Pro Tech工具包的订单免费送货!



与 #ImAGenius 分享您的维修故事


与 #ImAGenius 分享您的维修故事



Allow the battery to recharge to at least 25% before trying to start your machine. A full charge would be even better if it's capacity has dropped. Try to start and let us know your results including any sounds or lights and we can go from there.

There are 22 models in the A1286 line. Please give us the last three figures of your serial number so we can correctly identify your machine.


按维修分数 1


I also have a macbook pro 2010 15 inch and i cant get it to power on for the life of me. The screen just went out on me the other day and im in desperate need to get it up and running again. the last figures in my serial is rjc mine is also in the a1286 line. ANy help would be a lifesaver. The screen just randomly went black on me and now wont turn on. the battery says that it is full but nothing happens why i try to power it on. thanks again


The keyboard may be improperly connected, (and thus the power button disabled). Note that the keyboard connector has a lock that you need to disengage to connect or disconnect the Keyboard's flex cable.


按维修分数 1

Hi thanks so much for answering didn't think it was going to be that fast.

Three last digits from serial number it's 1 G A. Do you need anythin aside from this I can check up ? I did bridging the power pads but it's not turning on, battery charges fine. I checked the voltage on G3hot trace and it measures 3.4 .

I'm suspecting the SMC it's screwed.


按维修分数 0

I'm also worried any of the BGA chips might have desoldered. But as I've stated above i'm extremely careful about thermal cycles on laptops and this machine was fully optimized for airflow, in fact both fans were always running at 5900rpm. But I checked the nvidia MCP79 on the schematic cnnects with the SMC circuit and if it's desoldered might be bothering.. HOPE ITS NOT ! I don't want to reflow anything.


按维修分数 0


Juan Pablo 将永远感激不已

过去的24小时: 5

过去的7天: 27

过去的30天: 163

总计 10,427