跳转到主内容

2003 X5 no audio after battery replacement?

Hello bimmer friends. After new battery install in my 2003 X5 the audio is completely absent. No Prior issues with sound system and everything is factory. The radio still turns on and displays show normally, it can scan through stations and adjust settings/volume like always, but no sound. There is no crackling or buzzing or anything like that, just total silence in any mode, CD, radio, Bluetooth adapter.. silence. It doesn't ask for a radio unlock code or give me an option to enter one. Any ideas? Could it be an Amp issue? I've checked all the fuses, and there are no relevant codes showing in diagnostic... I can't afford a professional repair for a non-essential issue like this -keeping it on the road in one piece is bankrupting me as it is. Any advice would be greatly appreciated! Its been like this for months and im going crazy from long, silent drives when I forget my headphones....

已回答! 显示答案 我也有这个问题

这是一个好问题吗?

得分 0
添加一条评论

1个答案

已选择的解决方案

The most likely reason would be the new battery has fried the speakers themselves this is what happened to my Audi S7 when a new one is replaced sometimes the resistor is so old it can not take the amps given and fry the components Kicker audio has some the best and cheapest speakers on the market rn go to the Ds series car speakers find your car size and order then there is no need to upgrade anything else with this speaker's everything can be completely stock with this speakers and about 20-30 minutes to fix the issue. I hope this helps. :)

这个答案有帮助吗?

得分 0

1条评论:

Thank you so much I will try this. I never would have thought of that. So all I need is the new speakers not the Amp or resistors?

完成的

添加一条评论

添加你的答案

Jessica Kidd 将永远感激不已
浏览统计数据:

过去 24 小时: 2

过去 7 天: 10

过去 30 天: 20

总计 301