My PowerBook makes a clicking sound but it won't turn on, why?

My PowerBook G4, model A1138, won't start up. It chimes as if it were to start, but then it clicks over and over, and the screen remains black. There are no graphics or messages on the screen, but the start light comes on.

Before it broke, I was getting Kernal Panic messages pretty frequently, until it finally would not re-start.

The battery seems to work and it charges; meaning it's green or it turns red if I unplug it for a while.

I'm using the original power adapter, I'm the first and only owner. I tried starting it with and without the power adapter. I tried to start it in Target mode, but it didn't respond. It continued making the clicking "rotating" sound as if it were trying to start but can't.

I'm about to replace the hard drive, but would like to make sure that, that is the problem before investing the money. I took it to the Apple store but they wouldn't look at it because it's over 5 years old. However, the clerk suggested it was a bad hard drive even though he didn't look at it. He said if it were a bad logic board it wouldn't make any sound or even try to start at all.

I would appreciate any suggestions anyone might have. My PoweBook G4 has been great and I would like to keep it as a back up. Please help!

已回答! View the answer 我也有这个问题


按维修分数 1

所有超过US$100.00或包含 Pro Tech工具包的订单免费送货!



与 #ImAGenius 分享您的维修故事


与 #ImAGenius 分享您的维修故事



The clicking sound is usually the search head on the hard drive going back and forth. You can try stating up from your system installation disk and using Disk Utilities try to repair the hard drive, but if you can get it up at all, backup whatever data you can and then replace the drive. Here's how to replace your PATA hard drive: PowerBook G4 Aluminum 15" 1.67 GHz Hard Drive Replacement


按维修分数 2


You can replace the hard drive while the disk is still in the optical drive.

Thanks for the link, and for confirming that my PowerBook G4 needs a new hard drive.

I tried using the system installation disk first, and it got stuck inside. The computer won't get passed the clicking noise at start-up so none of the alternative ways of ejecting CDs work.

Is it OK to replace the hard drive while the disk is stuck inside? How can I eject the disk if the laptop won't start up?


Disconnect the hard drive and see if it boots from the installation disk. To eject the DVD after disconnecting the hard drive just hold down the mouse button on start up.


I have found that the clicking noise sometimes is because of a bad memory stick. Pull the memory and replace only one. Repeat with the next one. Still have the noise.? Try the other memory slot and repeat the proceedure. Sometimes just a cleaning of the memory sticks conecting pins with WD40 will work wonders.


按维修分数 0


Memory modules are solid-state, they just don't click. Don't ever spray any type of lube into your system! While wetting a Q-Tip with some electrical contact cleaner to wipe down the memory module contacts could help. Spraying is a big No No! The areas you get wet will collect dust and other junk like a magnet!


What was the solution?

I have the same problem with my mothers powerbook g4. I turn it on, hear the chime and then the clicking, which I believe is the optical drive initializing, and then it just keeps repeating the clicking like it is stuck in a loop. The display is black the entire time. I pulled the hard drive and was able to access it externally through another mac so I know it isn't that.

My thought is that it's the logic board but I don't want to replace it if that's not it.


按维修分数 0


Review Mayer's answer above - 99% of the time the HD has gone bad. You can prove this to your self if you have the original recovery CD that came with your system or a logo'ed OS CD you should be able to boot up with it. If you don't you'll need to get one or an OS install CD to re-install the OS in any case.

I will see if I can dig up the recovery disk and try to boot from it but like I said, I pulled the hard drive and hooked it up externally via usb to another mac and was able to copy stuff off of it. The clicking is coming from the optical drive as it is initializing on bootup. I am also going to try pulling the memory one piece at a time to see if that could be it. I will report back after my next steps.

It was late when I replied so I missed that tidbit, sorry ;-} That your drive is accessible externally from a second Mac, thats good! You still need to find the recovery CD to make sure the drive is accessible internally. Check your systems date & time (make sure your not connected to the internet when you do this) is it correct if not bingo! your CMOS batt is dead so your loosing your settings (boot drive setting) Which can explain why your optical drive is trying to load the OS instead of your HD's OS. Otherwise you'll need to re-install the OS as it's corrupt and don't forget to use the Preference Startup Disk to select the HD to boot from. If you can't see the HD then the drive cable is bad or did you replace the HD (this being the replacement drive)? If so make sure It is an Ultra ATA/100 drive and also double check your jumper settings Primary/Secondary (Master/Slave). Make sure you have it set for Primary.

No this is not a replacement drive. I am troubleshooting why the machine just one day decided not to boot up anymore. I am still trying to get ahold of the recovery cd, but in the meantime will any bootable disc work? I ask because I put a Windows bootable disc in and this is what happens - I hear the optical drive initialize and start to spin the cd, then it stops, initalizes again, starts to spin and stops, repeat, repeat, etc. Basically doing what it was with no disc in the drive. Do you still have faith the correct bootable cd will make a difference?

New problem: how do I eject the disc? Doh! There is a lesson in here somewhere: never give a PC guy a broken MAC to troubleshoot. Your help is greatly appreciated.

Hey you at least tried! Unlike those 'Other' systems you need a Mac OS disk as that 'Other OS Disk' won't startup your Mac ;-} Sorry you'll need to find it. To eject the CD/DVD restart the system and press & hold the eject key in the top right corner, or function key F12, or hold the trackpad button down.



I tried everything I could to get the disc out to no avail. I finally disassembled the optical drive and physically removed the disc but when I put it all back together it wouldn't let me put another one in, the drive was still thinking a disc was in because the mechanism was blocking the opening.

I ended up purchasing a new logic board. Got one for $90 online (refurb). It took about an hour to install but that finally fixed it. The laptop is now booting once again into the OS and everything looks good. Hallelujah!

Thank you for all your help.


按维修分数 0


Nijme Rinaldi 将永远感激不已

过去的24小时: 9

过去的7天: 41

过去的30天: 249

总计 14,928