Battery is not working properly


originally, I wanted to charge my old DSi XL. After I connected it with charger, the orange LED was blinking. I tried several other places to charge, later it worked. After a few seconds, I was able to start the DS. After I waited ‘til it’s potentially full, I disconnected it from charger. But: The battery goes down within seconds, so I can’t ply with it without charger. Everything works: all buttons, games will start, everythin works except of the battery. Then I bought a new battery and tried it. It looks like it charges, but sometimes, the Battery is at 3 Balks and seconds later on 2. I charged it to full until the orange light is away; same problem with the Battery. But as soon as I changed the battery, it is not blinking anymore. What’s still wrong? Is the battery not that good? It should be smaller than normal I have heard from internet. What is still the issue? But sometimes, it works without the charger and is not going down immediately. So it looks like a ‘Sometimes-Issue’ ? What can I do? Please help me! Ty (the LED is not green anytime when it’s potentially fully charged)

回答此问题 我也有这个问题


得分 0