跳转到主内容

A gaming laptop released by Asus with a CD/DVD drive.

18 个问题 查看全部

Black screen after cleaning and reassemblingm - RESOLVED

A friend of mine gave me a gl552vw that she wasn't using after my lenovo died. I disassembled it to clean it properly and to remove all the little inhabitants and apply new thermal paste. After reassembling it, all I get is a black screen. I was careful not to damage anything but the lid sensor broke off the board anyway. Do you guys think I might have damaged the lcd cable during reassembly or could the little inhabitants have done something inside it

edit: new issue discovered that i thought was normal. it turns on as soon as i plug in the charger

回答此问题 我也有这个问题

这是一个好问题吗?

得分 0
添加一条评论

1个回答

最有帮助的答案

Hi @techlord

Did you disconnect the battery from the motherboard when cleaning, you never said?

Connect an external monitor and check if there is a display on it when the laptop is turned on and booted up. If the external monitor works OK, then use a torch and shine it an an angle close to the laptop screen and check for any images. If you see them, (they will be very faint) then there is a backlight problem.

Normally the backlight power is on all the time when a laptop is turned on and it is turned on and off in the LCD panel by a signal voltage from the BIOS (and can also be from the OS to the BIOS) depending on requirements. You said that the lid sensor broke off the motherboard. It is the lid sensor that tells the BIOS whether the lid is open or not so perhaps it thinks that it is now shut so therefore the display is turned off.

这个答案有帮助吗?

得分 1

评论:

Everything was disconnected and I don't have a monitor so I used my tv and got no picture at all. I plugged in a hard drive and the there was no activity indicating it was trying to boot. I know it was working when it was given to me so I'm stumped as to what I could've done

完成的

@techlord

Any lights on the keyboard when a charger is connected and the laptop turned on?

is the lid sensor part of the power button board in your model?

Only asking because in some other laptops it is and the power button and sensor use the same cable to the motherboard.

完成的

i fixed it, i cleaned the ram slots and display cable slots with alcohol and a toothbrush and it removed whatever remains were there from the freeloaders inhabiting it

完成的

@jayeff it now works but turns on as soon as i plug in the charger and it's not supposed to do that

完成的

@techlord

The laptop never had a missing lid sensor before.

Don't know but try disabling "Wake up on lid opening" in BIOS and check if that does anything.

Go to BIOS > Advanced > Wake up on lid opening (see p.75 of the user manual)

The default setting is Enabled but it would rely on the lid switch to know if the lid was open or shut.

完成的

显示更多的13条评论

添加一条评论

添加你的答案

Cheap gamer 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 0

过去的30天: 7

总计 95