跳转到主内容

发布于 2012 年 6 月, 型号 A1278. Intel 处理器,支持 Turbo Boost, 最多 512 MB DDR5 显存

1534 个问题 查看全部

Can't detect fans/loud fan(s) after SSD addition/RAM upgrade

Hi.

I maxed out the RAM to 16gb/added an SSD and installed Catalina on it. Fans are loud even on idle with nothing running (with or without activity monitor). I’ve tried iStatistica Pro, TG Pro and Fanny to detect/control fans and detect temperature but none of them help with that. I’m using TG Pro on my MBP 2015 and it works perfectly fine.

On TG Pro it says it detects the temperatures for the HDD/SSD but that no fans are /the option is N/A. And in battery health it says ‘this mac does not have an internal battery.’ Unplugging the power adapter confirms that the battery is present but I suspect this is a software bug.

Did I &&^& up a sensor something up in the upgrade process? Could it be a software problem?

Would really appreciate help figuring out what to do.

Thank you.

已回答! 显示答案 我也有这个问题

这是一个好问题吗?

得分 0
添加一条评论

2个答案

已选择的解决方案

For anyone having this issue in the future reading this:

Someone on reddit suggested checking the battery indicator cable which I noticed wasn’t turning on. It was as simple as opening the lower case, just unplugging that cable with a spudger and plugging it back in. Now the sensors show a high temperature issue that’s probably a thermal paste one and was likely already there but I didn’t have a temperature app to see it. Good luck.

这个答案有帮助吗?

得分 0
添加一条评论

Try a PRAM reset and a SMC reset

do the following to reset PRAM on Mac:

  1. Turn off your Mac.
  2. Press the power button.
  3. Immediately press the Command+Option+P+R keys.
  4. Hold the keys until your Mac restarts and you hear the startup sound.
  5. Release the keys.
  6. SMC
    1. Shut down the computer.
    2. On the left side of the keyboard, press and hold the Shift, Control, and Option keys while simultaneously holding the power button.
    3. After 10 seconds, release all of the keys.
    4. Turn on your MacBook.

这个答案有帮助吗?

得分 0

评论:

Hi @mayer

Thanks for your response. I've already reset the SMC. Didn't help.

完成的

Next try the PRAM next. Also download Coconut Battery and post your results if you can.

https://www.coconut-flavour.com/coconutb...

完成的

@mayer I tried PRAM. Not sure if it's supposed to boot into anything other than the OS after a second time but it didn't do anything.

The coconut battery app doesn't detect anything regarding the battery.

Manufacturer, Manufacture date, serial, macOS battery status all show blank fields. Loadcycles = 0, Battery temperature = 0.0 degrees.

And the power adapter doesn't seem to be charging anymore. The power adapter options in the coconut battery app say "not connected."

Appreciate your effort.

完成的

添加一条评论

添加你的答案

Quimper 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 1

过去的30天: 2

总计 37