跳转到主内容

Model A1311 / Late 2009 / 3.06 or 3.33 GHz Core 2 Duo processor

288 个问题 查看全部

After HD replaced with SSD video looks like really bad VGA / whitedout

Late 2009 imac Intel EMC 2308 replaced Western D hard drive (500GB) with 1TB Crucial SSD.

I just bought the kit and followed directions for the HDD to SSD replacement. When I booted up with the new drive I did the hold option key and booted from a USB. From the start the display looked weird. Sort of pixelated and missing stuff, and whited out. I thought it might be a missing driver … so went ahead with the install. Nothing changed.

I did make sure that all the cables were attached to the display properly before putting everything back together. I was careful on the removal and putting everything back.

The display seemed to be making weird oval shapes right about where the hard drive was / SSD was replaced. I did put the foam on the HD. There was no problem with the fan starting as the new thermal sensor was installed properly.

Has anyone experienced this? I would appreciate any advice. - Thank you

Update (03/09/2021)

Block Image

This is what it looks like

已回答! 显示答案 我也有这个问题

这是一个好问题吗?

得分 0
添加一条评论

1个答案

已选择的解决方案

I figured it out. I hope this will help someone else in the future.

Fix: Check all the LCD connections for dust and being in its proper place.

What I did: So I carefully removed the glass, and started to remove all the LCD connections again per the hd fixit replacement manual instructions. When I got to the point of the LCD ribbon I noticed a few things. 1, it was a hair out of square with the receptacle. 2 When I removed it there was a spec of dust on the ribbon connector itself. 3. I had noticed that there was a sticky part of the ribbon which was previously connected or stuck (tape like stuff) to the main board area just near the hard drive space. I gently pressed that back into place.

Solution: I removed the spec of dust, made sure the ribbon was squarely connected. and as previously mentioned pressed the sticky tape down before connecting all of the other connectors. I also checked all of the other connections before putting them back together. Put the LCD back into place with the screws. I tested it with the glass off just to be sure. Viola it worked!!

Hope this helps someone else out.

这个答案有帮助吗?

得分 0
添加一条评论

添加你的答案

BCam 将永远感激不已
浏览统计数据:

过去 24 小时: 0

过去 7 天: 0

过去 30 天: 1

总计 13