Sumup AIR Card Reader Model: AIR1E205

1 个问题 查看全部

The Card Reader becomes "blocked" after receiving a small shock/hit

The Card reader fell to the floor and received a shock, not when booting it up it says “Device Blocked.Please ContactSupport” support tells me that this is a “fail mechanism” that gets triggered by droping it

the only way to “fix this” is to get a new one

So.. i opened the card reader. seems there are 2 Pads with a coper lining in them that are never ever supposed to contact the board pins underneath the pads, and if the device gets dropped hard enough the pads will cause the pins underneath to contact each other.

Also on the other side of the board is what apears to be a other small connectorboard that is fitted in a way that if it would be dropped, the small connector board would disconnect from the other part, causing it to not make a connection anymore

This device is ment to be caried around and use mobile. So offcourse this kind of fail mechanism is totally idiotic

And offcourse it broke just 2 days after the warranty was over

I am trying to get this back to work since im not a fan at all of this kind of nonsense to get people to buy more stuff while the other unit the are replacing is technically still functional

I tried removing the sodim inside, removed the foam pads with the copper lining and soldered the lifted of small piece back to its place

Only thing i mannaged to do is reset the date and open a service port on the device (trough usb connection)

If anyone has a clue on what i can do, please tell me

Block Image

Block Image

Block Image

Block Image

Block Image

回答此问题 我也有这个问题


得分 0


With devices like this, they tend to have tampering traps in them to kill it, as it is a PCI compliance requirement. Disconnecting the coin cell probably dumped the encryption keys.

In this case, call support and deny opening it - just tell them it was suddenly blocked. It likely needs a hardware repair, so hopefully there were no tamper seals.


得分 0


They themselves aknowledged that the Fail mechanism gets triggered by drops/hits and its the way they designed it.

But as long as the board and chiplets are fully functional it should function fine.

(Atleast thats what i expect, when i repair a pc or a old gpu its exactly that way)

They expect people to never ever drop a device used on the road all the time. Kinda weird to expect that tbh.

What if your laptop screen broke and youd replace the screen yourself and suddenly you would be "locked out" of the laptop because of opening it up and triggering some stupid mechanism.

That would be total bs right?

That is why i can't believe this device is "broken", touchpad works, card reader mechanism works, charges normally, screen works, bluetooth works. this card reader only has to do those things

There was no tamper seal just a badly glued sticker that came clean of without a scratch


@Red Angel Unless you can somehow find out how to get the encryption keys back, there's not much you can do sadly - the battery retains the keys and they get dumped when you open it or remove the battery.

PCI compliance is no joke.


First i tought, if a bios of a old pc acts up or behaves weird i just unplug and replug the sodimm,

So maybe if i replug the sodimm here it will reset the "Fail Mechanism" check

Apparently these modern tiny devices are made to break by doing something thats normal on any other device :/

I really hate it...


@Red Angel Blame the industry for being so strict.



I have just had a chat with Sumup support with a

“Device is Blocked. Please contact support [0105000000]” - Message

I purchased my device 3-4 years ago. After receiving it I initially set it up & it has spent the remainder of its time in the Box it arrived in (Completely un-used)

The trigger for my blockage isn’t shock, impact nor tampering! it’s because

“I haven’t charged the battery regularly enough?” according to the support team?

I queried if this apparently timed (Self-Detonation) feature was mentioned in the

“paperwork that I would have received when I purchased the card reader?”

The answer that I received was

“It is advised to charge the Battery regularly, To prevent damage to the Battery!”

I then asked

“Is the Blockage due to Battery failure?”

To which the obvious answer is NO. The Battery was Flat, so I connected it to my PC & I was immediately greeted by 4 illuminated lights & the message above… The Cardreader remained connected to the PC whilst I spoke with the customer support team (Approx 15 mins) I removed the Cardreader from the PC & low & behold the Battery had charged??

I explained to the Support team that

“I repair electronics - Micro soldering - IC replacement, Jumper wires, Board trace repairs etc. requiring the use of a microscope & have a very in depth understanding & knowledge of Board level electronics, specifically SMC’s”

I asked the support team

“Why has the anti-tamper trigger been activated? is it due to a failing battery? if this is the case, then it does not constitute tampering??" even though the Battery isn’t failing & is charging as normal

The response was

“I’m sorry, I don’t know but because the warranty has expired, we are not able to help you!”

I explained to them that because this unit was now a paperweight! & as such I told them

“I am now out of pocket, I have no intention of replacing it but will quite happily upload a video to my YouTube Channel showing my disassembling & reverse engineering this unit! in order to ascertain the Trigger mechanism & how to circumnavigate it & whilst I am in the process I will list every IC & major component contained within it! & where to source them all!”

I also made them aware of the fact that there are bound to be several thousand people that will be quite happily entertained whilst watching this video

I made them aware

“If I am unable to use this cardreader for it intended purpose to earn me money then I will earn money from YouTube dismantling the damned thing”

At this point after reading my intentions, I was promptly informed by the support team that

“The Technical Department would contact me as a matter of urgency. with the intention of resolving this issue!!”

If I haven’t heard anything within a couple of days, I will proceed with the Video :)

(There will be alot of interested parties that are a lot smarter than me that will take alot of interest in my findings)


得分 0

I’ve the same issue with my Air terminal. We use that device in our taxi and suddenly it broke today at 8:45 am. This %#*@ thing never touched the floor or anything else and it’s always charged. The device is out of warrenty since February 2021.

Support sad to me the same thing “we can’t do anything else. Please buy a new device”.

Were you be able to find out anything regarding electronics and reverse engineering?


得分 0

Hi, I have only just began to dismantle my Paperweight (SumUp Reader) I will upload my findings at a later date but currently it seems as though the only way to reset the configuration is with an interface (I haven’t figured out which as yet?) but have I have tried several various software methods. I have managed to make the device discoverable but non writeable! Once I have uploaded the Board & component details (Photos) I am hoping that there will be others that will recognise them & maybe able to offer a schematic?

Unfortunately at this moment in time, I am afraid that a replacement unit is currently the only quick fix solution


得分 0

Yep, I bought a new device so we can further accept payments.

I also found this topic while I was doing a small research


He listed some of the components of the Sumup Air Terminal. Maybe it could be useful.

I guess if we want to reset the device we need to unsolder some chips right?


得分 0

Did you manage to fix this? I have a similar problem and my card reader was not dropped…


得分 0

@norman ludgate

unfortunatly not. I throw the broken one away and bought a new one.


得分 0


Red Angel 将永远感激不已

过去的24小时: 7

过去的7天: 77

过去的30天: 391

总计 987