跳转到主内容

MacBook air doesn't power on. Shows no signs of life besides charge li

Early 2015 11 inch macbook air

Macbook doesnt power on or show any signs of life besides charge light. I took it apart and saw no obvious signs of any damage. I was told that it needed a logic board replacement, but wanted to see if there is another option.

What I did find, is that the power button does nothing, but when I short the jumper inside the light goes from orange to green and then back to orange again after a second or 2

I tried a pram and smc reset with no luck. Also tried disconnecting everything with no luck. I left it sit for a bit all unplugged with nothing either. Anybody know what might be wrong, or anything to test

Update: 8/9/19 Did some voltage testing on batt connector. Not sure if this is how it is supposed to be, or if this helps anyone. From what I can gather, 1 2 and 3 are negatives and 7 8 9 should be positive from the schematic, although it is switched where 7 8 9 are neg and 1 2 3 pos. But I have it looking at the connector, with the dc in on the right, going from left to right (pin 1 is far left)

Dc only

  1. 0v

2 . 0v

3. 0v

4. 0v

5. 3.5

6. 3.5

7. 8.6

8. 8.6

9. 8.6

Battery Only

  1. 0
  2. 0
  3. 0
  4. 0
  5. 0
  6. 0
  7. 0

8. 0.7 (Was about 1 but dropped for some reason)

9. 0.7 (Was about 1 but dropped for some reason)

Dc plus Battery

  1. 0
  2. 0
  3. 0
  4. 0.23
  5. 3.3
  6. 3.3

7. 0.23

  1. 0.23
  2. 0.23
回答此问题 我也有这个问题

这是一个好问题吗?

按维修分数 1
添加一条评论

1个答案

最有帮助的答案

If you’re up for testing you can probe battery pins and see if you have the 8v and the 3.4v power lines. If you do you can rule out I/O board and you’ll know main power lines are up and running. If you have no voltages it would be worth to try and replace the I/O board, such repair attempt would be quite cheap and easy to perform. In case of failure a component level troubleshooting or board replacement would be the two alternatives.

这个答案有帮助吗?

按维修分数 3

评论:

Ok thanks! Ill check that out tomorrow

OK, so if your looking at the board with the dc connector on the right, the pins for battery connector go as follows.

(left to right)

The first 4, nothing

The next 2 were 3.4v

and the last 3 were 8.6v

is that normal? I was also getting 16.48 volts right at the connector to the board without the battery plugged in, and the same with it plugged in. But its only on the first 2 pins, the other 4 show nothing (left to right)

Also, whats weird to me is that even without the battery, the light on the charger goes orange after a second. On my older macbooks, if the battery was dead or not there, it would just stay green. Now i dont know if this was changed but its weird to me

@cam2363 It's everything normal as far as voltages are concerned and an I/O port swap isn't likely to make any difference. Behavior of the magsafe has changed in time and an orange led can be expected unless battery is connected and fully charged. Unfortunately from here on troubleshooting gets tough as there are tens of power/data lines that may potentially be the cause.

@arbaman alright thanks. I'll maybe look into it a little more. Sounds like a board replacement might just be the best bet

@cam2363 I wish I could provide further guidance, but on these boards there's no real "usual suspect" to chase unfortunately.

显示更多的4条评论

添加一条评论

添加你的答案

Cameron 将永远感激不已
浏览统计数据:

过去的24小时: 1

过去的7天: 7

过去的30天: 17

总计 73