Galaxy s5 won’t boot up

Please can someone help me with a problem I’m having with my Samsung Galaxy s5.

I put my phone on charge before I went to bed and when I woke up it was still showing a red LED. I knew this was wrong because it should have had enough time to charge and turn green. I had not powered the phone off before putting it on charge and I plugged it into the same USB 3.0 charging lead I have been using for the past six months. I unplugged the phone and pressed the power button to light up the lock screen but it didn’t light up.

I’m thinking possibly something has either shorted or got fried while it was charging because I tried several possible solutions I found on google but nothing has worked.

I tried removing the battery and waiting 10 seconds but the phone just goes into a boot loop where the phone vibrates before the Samsung logo appears but then it just starts to loop but wont boot up.

I have also tried the spare battery I have but it’s still the same. I know the spare battery is 100% fully charged because I store it in a separate charging box which shows a green LED when it is full.

When I plug a different USB 2 charging cable into the phone, without trying to power on, the charging icon appears but shows no charge at all in the battery. I’m confident both batteries are fine and not faulty because they both showed a green LED when in the charging/storage box.

At this point I removed my sim card and also the MicroSD card. Removing the SD card didn’t solve things.

I have tried removing the battery and holding the power button for 60 seconds to dissipate any residual charge and then power on again but it still just loops.

I then tried booting into safe mode. This time it did show my lock screen for a few seconds but then the display started breaking up and the phone powered off and went back into it’s loop again.

I tried getting into recovery mode but again all I get is a quick vibration, the Samsung logo and then back to the same loop again.

Same story with download mode also unsuccessful.

I have tried pressing and holding Vol-down when plugging it into my PC using a different USB 2 cable and windows acknowledged a phone was plugged in but said it couldn’t connect or recognise the phone and suggested the phone could have a fault.

Some power is clearly getting to the phone if it can get as far as showing the logo and trying to boot but when the charging cable is plugged in it indicates the batteries are empty even though I know they are both fully charged.

I don't know if maybe my USB 3.0 lead has a fault or if there could have been some electricity spike while the phone was plugged in. As I’m not a phone engineer I have no idea about how to trace any possible hardware issues. I would really appreciate any help or suggestions anyone can offer as this has been a great phone for the last 2 years since I got it and I’d be sad to have to junk it and buy a new one.

I'm guessing either the charging port or something on the board has burned out but it would help to have some idea before I approach any repair shops.

Thank you.

回答此问题 我也有这个问题


得分 0