跳转到主内容

Why is my new main camera not working?

So, i ordered some replacement parts for my huawei p9 lite(Main camera, front camera, usb board), Everything i replaced is working, except for the main camera, the new main camera isn’t working, because when i open my camera app it immediately closes, snapchat shows me an error that says: Snapchat was unable to open the camera app. I made sure that the new main camera isn’t working for some reason, because when i put my original camera back in, everything works, including the new front camera). Am i missing something, could it be a hardware problem or a software problem? Please help, i need advices quick. Thanks.

已回答! View the answer 我也有这个问题

这是一个好问题吗?

按维修分数 0

评论:

camera part was an exact match of the old part?

The replacement camera is the same as the old one, except for a 4 digit number, and a sticker on the top of the connector

this could be the issue, you might have to debug to confirm. I am not an expert on that so i will let one of our other find folk talk about debugging.

Okay, thank you, will the folk get in touch with me anytime soon? Because i don't know anything about debugging either. By the way, i put a link up, just to show what the differences i am talking about are. https://imgur.com/a/vMzUy4l. Could this really be the cause of the problem? Because other than that, the original and replacement cameras are absolutely identical.

only thing I can think of that may cause it. unless your software changed at the same time

显示更多的2条评论

添加一条评论

1个答案

已选择的解决方案

Okay so, i got in touch with the supplier, he sent me a new replacement, and now everything works, it means the new main camera was potentially defective. Thank god it wasn't a software problem, that would have been !&&*.

这个答案有帮助吗?

按维修分数 1

评论:

Wanna link the supplier for others?

添加一条评论

添加你的答案

Zygis Bugenis 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 0

过去的30天: 0

总计 77