跳转到主内容

Mac Pro wont power on, red LED?

Update:

First, sorry for the hiatus. I've been out of the business for a while. But I'm back!

Apple couldn't tell me anything. They offered me to pay a flat $500 fee, and they would replace anything that needed to be replaced untill it worked…

I ended up just selling it for parts…

So I have a Apple Mac Pro "Quad Core" 3.7 (Late 2013) that wont power on.

I do not know the history of the machine.

I plugged it in and got nothing, no beeps. no fan spinning, no response.

I do all the normal procedures, swapped ram, tried different SSD, reset SMC, tried different power cable and outlet. None of that worked.

I took the case off and found a bright red LED shinning.

Block Image

So I started searching the internet, thinking that there MUST be some information about this red LED.... NOTHING!!!

So I proceeded to take the whole thing apart, took it down to bare bones to make sure everything was connected properly and to see if I could find any corrosion from any liquid damage or such.

While I was at it I re applied thermal paste on both the CPU and GPU.

Nothing appeared to be out of place, no damage to the board, all connections were secure.

I put it back together, powered it on, and still nothing, just the red LED...

WHAT IS WRONG WITH THIS THING!?

Please, if you have any idea what could be wrong, any suggestions, or any explanation about this red LED I would LOVE to hear it.

I'm totally baffled by this one...

Thanks in advanced,

Taylor

回答此问题 我也有这个问题

这是一个好问题吗?

得分 1

评论:

UPDATE:

I tried different types of RAM, Low voltage RAM, and ECC RAM... No luck.

Based on someones suggestion I tried booting without one of the two graphics cards plugged in, no luck there.

I am at a loss.

Is thing just not gonna boot for me?

完成的

Same issue. In my case, the red light was coming from the bottom of the unit, the logic board. I replaced the logic board and was back in business. Turns out, it had been dropped. Dent on the bottom and the riser stand-off screws holding the logic board in place were broken.

完成的

添加一条评论

2个答案

Hi! Did you solve it? I have the same problem. Best regards Petter

这个答案有帮助吗?

得分 0

评论:

Same problem. Plz, help in a advice.

完成的

添加一条评论

Any luck?

Was just handed a mac pro with exact same problem. This was after upgrading CPU.. only a red led on psu board lights when power cord plugged in and another red LED on the bottom (round) logic board. pressing power gives no life of any kind.

这个答案有帮助吗?

得分 0
添加一条评论

添加你的答案

Taylor Struna 将永远感激不已
浏览统计数据:

过去的24小时: 1

过去的7天: 11

过去的30天: 52

总计 2,243