跳转到主内容

修复你的物品

维修的权力

商店

2.2 GHz (Turbo Boost up to 3.4 GHz) or 2.5 GHz (Turbo Boost up to 3.7 GHz) quad-core Intel Core i7 processor with 6MB shared L3 cache.

387 个问题 查看全部

Green tint on black / dark screen?

Block Image

Block Image

https://imgur.com/a/ZfaU5xC

Not sure what's wrong with my macbook screen.

It's showing green stuff on dark screen.

But they are perfectly fine on white / light colors.

Also the green goes out on it's own after 1 hour or 2.

回答此问题 我也有这个问题

这是一个好问题吗?

得分 5

评论:

Are you sure the issue is the Mac and not the application you are using?

完成的

No I'm pretty sure it's not. That application is Sublime Text, also they are like that on Black pictures of Chrome, or any Video that has dark screen.

完成的

添加一条评论

2个回答

最有帮助的答案

Unlike the older MacBook’s which used LVDS signaling the newer retina systems use iDP signaling which is a very different signaling system. So the symptoms of colored bands and screens for a bad cable don’t show up here. This system is either a bad driver within the display or the logic board’s GPU logic.

What happens when you use an external display does the external exhibit the same behavior? If it does then the GPU logic needs to be looked into (likely needing a new logic board). If on the other hand the external display looks OK and the internal shows the bad image then it’s within the display and would need a new display assembly.

这个答案有帮助吗?

得分 2

评论:

Did you guys find a solution to this? I am facing the exact same issue. There is a green and pink tinge to the whole screen when I switch it on or open the laptop after a few hours. [br]

But the same tint goes away in the next 4-5 mins

完成的

It is the display panel. Don’t go for confusing solutions like PRAM or SMC reset, they don’t reset the display problems. I fixed my issue by replacing the entire body with a new display. Problem gone.

Here’s a link to my query on the same and the solution

Why is my display starting in Pink tint after coming back from sleep?

完成的

添加一条评论

Hi! Encountered exactly the same problem. I already Reset the SMC, PRam and NVRam but nothing happened. I already reset and installed fresh MacOS but still the issue is still there. As long as my MBP 2015 13” is not heated like for 10 to 20 min the green haze / tint is there or as long I the display is not closed after you open for 10 to 20 min. What did you do to solve the problem? I don’t think the problem is within the display. Any solution what did you do with your unit? Thanks.

这个答案有帮助吗?

得分 0

评论:

What does the external display look like? If you see it the off color there then you have a logic board failure. If you only see it on the internal then the internal display will need to be replaced.

完成的

External display looks fine. It only appears when you first boot after 10-30 minutes of use it disappears but when you see to it closely after, the display will have mark or looks like a LCD burn of your previous display. Is there any fix if the logic board failed to display the right display? As I notice the green tint sometimes move on the side near the bezels of the screen as I close the lids of my MBP 13" 2015.

完成的

Sorry to say if the image on the external is clean all of the time then the issue is not your logic board as thats where the GPU sits that drives either displays.

Did you have a liquid spill or sit your system down on a wet surface? Your logic board could have been damaged where the internal display is attached otherwise your display is likely just showing its age. Screen Burn-in is a common sign the screen is getting old.

完成的

I barely used my laptop once in a while and I have notice that the green haze/tint is not at the same place all the time. But most of the time it is located at the center of the screen. Normally I used the dark mode but not I switch to Light mode because it really annoyed me when I started my MBP 2015. The haze goes away after 30 minutes to 1 hour of used or as the laptop heats up when using. Also it lessens the haze/tint when I do SMC resetting. Any idea for a permanent fix regarding this? Tried several resets even I did reinstall the mac os and back to zero. So far it works perfectly just the green haze upon start up that made me annoyed. Thanks for the help.

完成的

添加一条评论

添加你的答案

David Mandeeli 将永远感激不已
浏览统计数据:

过去的24小时: 3

过去的7天: 28

过去的30天: 173

总计 7,479