跳转到主内容

Computer Turns on but nothing is displayed

Okay I am stuck on this one. The computer does turn on but nothing will display. The fan spins and the lights on the power button does turn on. Just nothing shows up on the screen. I hooked it to an external monitor and nothing displayed so I thought it could have bad integrated graphics. I ordered and replaced the motherboard, since it is an all in one computer, but I got the same result. I tested my hdmi cable and monitor and they work so I know its not the motherboard or external monitor. I have unhooked everything except ram and cpu fan from the board and that didn't change anything. I removed the ram and it beeped so I know it is doing POST but there isn't any beeps when everything is plugged in. One thing I noticed is that the keyboard and mouse will not light up even after 30 minutes of being plugged in. I know the power cable works because I have to repair basically the exact same computer and I am using the power cable from the first one with it. I don't see a seperate power supply so I believe it is built on the board somehow. So I am not sure where to go because it seems to not be the board and it is going through post but doesn't make a beep. Any ideas?

回答此问题 我也有这个问题

这是一个好问题吗?

按维修分数 0
添加一条评论

Android 维修工具包

A new screen or battery is one kit away.

现在开始购物

Android 维修工具包

A new screen or battery is one kit away.

现在开始购物

1个答案

Well, I can tell you this.

the beeps are supposed to indicate errors (RAM Failure, Boot Drive not found, etc).

You already concluded it's not the RAM, Harddrive, Motherboard, PSU or I/O ports.

But it seems the only logical option would be the screen itself not working.

Try replugging the screen of the computer itself if that's possible.

Otherwise try to take it to a repair shop and they can most likely fix it.

这个答案有帮助吗?

按维修分数 0

评论:

The thing is it has a hdmi port to where it can hook to a external monitor and that doesn't work either. I have unplugged the screen and hooked the hdmi to it and it didn't change anything. Put it back and the same thing happened.

Any ideas anybody else?

it's the RAM. unplugging the ram will never give you a successful post Beep. What you are hearing is "Oh crap there is no ram present beep"

Try replacing with known good RAM and try again.

I tried some different ram and I get the same result

添加一条评论

添加你的答案

Carlos Ramirez 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 0

过去的30天: 1

总计 82