跳转到主内容

Released April 2015, also known by model name A10-70F ( 'F' representing that this is a wifi only model)

46 个问题 查看全部

Reboot loop when charger plugged in

Hello!

Since a few months the tablet keeps on rebooting when a charger is connected, it always only reaches the first static splashscreen and then cycles anew.

I tried already replacing the battery with a new one but so far that didn't seem to have fixed the problem.

Since I replaced the battery I can access the desktop of the device, i.e. I can boot it all the way up normally although it will then give the critical battery level error and shutdown automatically after a few moments, when I connect the charger before it shuts down automatically it instantly reboots and loops again.

I also tried doing a hard factory reset using the recovery menu accessible when pressing power + volume up (only accessible if I unplug the device from power, else it will loop again).

Then I tried turning off the feature that it turns itself on when a charger is connected, using fastboot, which didn't help either.

I then tried flashing the factory ROM onto the tablet using SP_flash, that didn't fix anything either sadly but it was worth a shot.

Currently I am trying a script to force the device to charge the battery, or better said give it time to charge it by looping the reboot into fastboot, as it seems for some reason tablets only charge their battery when the screen is turned off on critical battery status, here is the script appended

@echo off

:start

fastboot getvar battery-voltage

fastboot reboot-bootloader

ping /n 6 localhost >nul

goto start

The script by the way has a rather interesting non existing output... it seems like getvar battery-voltage keeps on being empty, I thought at first that maybe the voltage sensor is broken but after some research in google I realized that even working devices seem to have no output there, while others do.

With that last attempt I am trying currently to charge the battery above the 30% mark so it theoretically can boot normally and stay turned on.

Alright, so with that I am at the end of my technical dialect and my ability to search google so I am asking you guys if you have another suggestion which I could try or anything else besides sending it into service, I am a computer technician and usually don't service android devices so I have no clue what else is possible, thanks in advance!

回答此问题 我也有这个问题

这是一个好问题吗?

得分 2
添加一条评论

3个答案

I have the exact issue with my lenovo A3500

这个答案有帮助吗?

得分 0

评论:

Was u able to solve it ?

完成的

添加一条评论

Hello,

I have the same problem and I am a technician too. :)

Did you find any solution for this?

这个答案有帮助吗?

得分 0

评论:

My problem was the battery, I have change that out and now everything fine.

完成的

添加一条评论

I have the same problem in Lenovo A536

这个答案有帮助吗?

得分 0
添加一条评论

添加你的答案

Daerevardul SIlverblade 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 4

过去的30天: 33

总计 3,832