Could someone help get device drivers downloading?

Hi guys,

I wasn't sure if i could post software issues on here, but I figured to see if you guys could help. Well I assume its software,

So, every time my sister tries to plug an item into the usb it doesnt install the drivers. it detects it, but the device manager reads it as error 28 . this only started after one of two things, not sure which. it started after i installed the SCP toolkit, which is software that recognizes a ps3 controller as a valid gamepad for the pc.

Heres the hitch,.

As for the SCP, it runs and functions on my computer fine, with no real adverse effects. I have an hp notebook too, just a different model. an additional note she runs windows 8, and I run 7

the only real issue I had was if you install the ps3 drivers while other things are connected the pc will now detect them as ps3 controllers causing them not to function. To fix that you uninstall the ps3 drivers, and disconnect all your usb stuff, and make sure you install the ps3 drivers without anything else plugged in. Everything will install fine as long as you dont install ps3 drivers with other things plugged in. They all function normally as long as you do this.

So naturally iI thought this was the issue, so I tried uninstalling the drivers. However this changed nothing

The keyboard on my sister's notebook is busted . so without usb keyboard working its difficult.

In addition to this, the computer has no issue running certain old usb items, like the printer and scanner.

one more thing, I know the usb devices work because I tested them on my computer.

Thank you for your time! I really appreciate you guys!


her device manager:

Block Image

Block Image

Block Image

回答此问题 我也有这个问题


得分 0



Just verifying that the Win 8 laptop has the pre-requisite software installed that the Scp Toolkit needs?

This is from the download page:

"ScpToolkit is a free Windows Driver and XInput Wrapper for Sony DualShock 3/4 Controllers. Installation is fairly simple and straightforward, but does require a few things: Microsoft Windows Vista/7/8/8.1/10 x86 or amd64, Microsoft .NET Framework 4.5, Microsoft Visual C + + 2010 Redistributable Package, Microsoft Visual C + + 2013 Runtime, DirectX Runtime, Xbox 360 Controller driver (already integrated in Windows 8.x or greater), at least one supported Sony DualShock 3/4 controller and Administrator rights during driver setup. (Did you do the Administrator rights when you installed?)


To be honest, I'm unsure. she completely removed the SCP software. She just wants to get a mouse and keyboard working on her pc. If its important to get the mouse working I can look, do you want me to?

also i do believe it was installed with administrator rights.

thanks for the speedy reply!




Try uninstalling all the USB controllers in Device Manager.

restart the laptop and let Windows 'find' the new hardware and reinstall the drivers for them.

Be careful if you have a mouse working that when you uninstall the USB controller that it is connected to you will lose ability to control the PC given that you have no keyboard to navigate with.

Difficult but perhaps if there are two controllers you can do one at a time. Pick the right one of course.


Ok, so her track pad works, so I would uninstall it. we have uninstalled and reinstalled a butt ton drivers, but we're willing to try just about anything to get it working. :)

So, I'm going to upload a screen shot of her device manager, can you please tell me which one to uninstall? just for safe measure.





Scroll down to Universal Serial Bus Controllers, click on the + sign next to it to expand the list, then right click on the first "USB Host" and select Properties then select Power. The info should tell you if anything is connected to that host.

If nothing shown close the Properties window, right click on the same USB Host entry again and select Uninstall.

Do this for all USB Hosts. Then restart the laptop.