2.26 or 2.4 GHz / White plastic unibody enclosure

678 个问题 查看全部

MacBook 7,1 - Not Your Usual iSight Camera Issue

Just a heads up, this is a bit of a long read, but I think it is an obscure problem amongst MacBooks.

Good evening fellow Mac users,

Let me introduce my computer and my self. I'm Evan, and have an a1342 Mid 2010 MacBook, has the 2.4 GHz Intel Core 2 Duo processor, 8GB of RAM, and a 250GB Samsung SSD. Currently runs macOS 10.12.2. I bought it in 2014 from a high school that had Macs for 1 to 1, and would sell them after three years of use. Got it for $300 in 2014, and invested in the RAM and SSD upgrade. When I purchased my Mac, it came with either Mountain Lion (10.8) or Mavericks, I can't recall. I've kept it up to date over the years for the most part. Anyway, since I've owned it, it's iSight camera has never worked. It doesn't bother me, as I very rarely if hardly ever use FaceTime, or video chat of any sort, however, it would be great if the darn thing did work. I've done plenty of research, and have even replaced the camera, the cable, etc, to try and remedy this, to no avail. I finally just chalked it up to it probably being the board. I tried everything before replacing components, SMC/PRAM, fresh install, all to no avail. Finally gave up on it. This was all in 2014.

Fast forward to now. I've since expanded upon my computer repair skills, and decided I'd revisit this issue. I work in computer repair for a living, and very rarely do I see Macs. Maybe once or twice a month. Boy are they generally a breeze to work on compared to some PCs, anyway... the reason I revisited my camera issue, well, one day a while back a MacBook Air came into where I work, with no functioning keyboard or trackpad. The kicker, they would both work before macOS was booted. They would work in the recovery menu, and they would work in PartedMagic, but not once booted into macOS. For those of you unfamiliar with PartedMagic, it is a distribution of Linux that has many different utilities and it supports all different types of hardware. Even tried a fresh install with a new drive. No dice. This got me thinking about my camera issue again. So today I booted into PartedMagic from my utility flash drive, checked system profiler, and voila, iSight camera detected!

So, I come to this forum, in hopes that someone agrees with me, that this literally makes no sense at all. This leads me to believe that it's an issue between macOS and firmware. My guess is it would be a problem on the firmware level, but you'd think over the years of firmware updates the issue would have gotten fixed. My firmware is current for my Mac. I looked into reinstalling the firmware from the page found here, but alas it came up and said "This software is not supported on your system." I'm assuming that's because I'm running a way newer version of macOS than those installers were intended for. I'm thinking to further troubleshoot this, when I get back in office Monday morning I might take another drive, do a fresh install of Mountain Lion, and see if it picks up on the camera then, if not I'd attempt a reinstall of the firmware with the older OS and see if I get my camera back.

I'm open to suggestions, and I want to hear feed back. I want to hear your guys' thoughts on this. Has anyone else experienced a similar issue? Seemingly failed hardware in macOS, but works otherwise.

I want to cross post this on different forums in hopes that more people will see it and or will have experienced something similar. After all, this type of "issue" doesn't seem to affect just one type of Mac. Referring to the MacBook Air with the keyboard and trackpad issue. I'm glad the peripheral that failed on mine didn't happen to be critical. 

Block Image

Block Image

Block Image

已回答! View the answer 我也有这个问题


按维修分数 0

所有超过US$100或包含 Pro Tech工具包的订单免费送货!




Create a fresh bootable external drive (ideally FireWire, but USB will do). Then boot up under it using the 'Option Key' during the boot to make sure its the boot drive. Does the camera work then?


按维修分数 1


I have news guys! Dan takes the cake on this one. It was indeed corruption on the drive. It surprised me that that's what the problem was, having tried a fresh install and all on a formatted drive. The ultimate solution was to boot into Recovery Tools, and run FirstAid on both the drive and then the partition which macOS is installed. It brought my camera back to life in macOS. Granted, I must still have a bit of a touchy connection somewhere because if I move my LCD assembly just right my camera randomly disconnects. That can at least be easily troubleshot.... checking connections. I'm going to try the same thing on that MacBook Air I made mention of with no keyboard and toucpad.



evanpiveral 将永远感激不已

过去的24小时: 0

过去的7天: 2

过去的30天: 14

总计 231