跳转到主内容

Model A1013, A1052, A1085, or A1107 / 1440x900 screen resolution

153 个问题 查看全部

No sound from PowerBook G4 17" internal speaker after HDD change

I followed the instructions on ifixit to replaced a crashed hard drive on a powerbook G4 17" 1Ghz.

I think I might have pulled the audio ribbon cable a little too hard when I was taking it apart.

After installing the new hard drive and reinstalling the OS (10.6), I realized there is no sound coming from the internal speaker.

Sound from the audio jack is okay.

Here's what I've tried:

  • Zap PRAM
  • Reset Open firmware
  • Checking Audio under system preferences to ensure it's not on headphones
  • Removed and installed the audio ribbon cables a few times

I've already ordered a new ribbon cable, and still waiting for it a arrive.

But what I don't understand is, I don't see any signs of damage on the current ribbon cable.

Is there any possibility something else is not right?

Update:

Ribbon cable arrived, changed it, but still no sound.

I've tried pushing on the logic board side of the cable while playing some music, no sound. Tried to fiddle around with other connectors while the PowerBook is "live" and playing music. No sound.

Just ordered a replacement audio board. Hopefully that is the source of the problem.

Latest update. Got the replacement audio board that came with a ribbon cable. Got them fixed into the Powerbook and still no sound.

I've also double, triple checked all connections and there is no breakage or loose connection.

Help!

已回答! View the answer 我也有这个问题

这是一个好问题吗?

按维修分数 2
添加一条评论

PC 笔记本电池

An easy fix for a big power boost.

现在开始购物

PC 笔记本电池

An easy fix for a big power boost.

现在开始购物

7个回答

已选择的解决方案

one or more legs under the speakers socket on the motherboard may be desoldered if you applied to much force removing the connector. Open the top case and apply a little pressure on the connector with a spunger while booting the PB and if you got sound then you'll have your answer. Now to resolder the socket is another game, that's micro soldering and the pins are under the socket.

这个答案有帮助吗?

按维修分数 1
添加一条评论
最有帮助的答案

The small board near the hard drive, containing the 1/8" jacks also contains the audio chipset. It's a good sign the board and ribbon cable going back to the logic board are ok, since you get audio out from the headphone jack. Double-check the black cable going to the speakers, as that is what is probably loose.

PowerBook G4 Aluminum 17" 1-1.67 GHz Speakers Replacement

这个答案有帮助吗?

按维修分数 5
添加一条评论

you could have damaged the part where the ribbon connects to the speakers or logic board, so I would check those

hate to ask the obvious but did you try turning it up?

这个答案有帮助吗?

按维修分数 0
添加一条评论

Thanks for the advise.

Will check the connector on the audio board under a magnifying glass later. That was the part that I used some force to remove the cable.

Yup, turned the volume all the way up.

Anyway, I knew the internal speakers connection was screwed when I zapped PRAM and there wasn't any chime.

这个答案有帮助吗?

按维修分数 0
添加一条评论

I have no answer. I have 2 G-4 PowerBooks 667 and 1 just recently has lost internal sound and I have 1 G-4 867 that has lost sound now for 2 years. Sound works with earphone jacks on both computers. I wish apple would give a response why so many G-4 laptops have this problem

Bounce

这个答案有帮助吗?

按维修分数 0
添加一条评论

Your issue is very likely to be that system 10.6 is not compatible with PowerBooks. 10.6 is designed only for Intel machines, not Power PC's. This is how to check....boot your PowerBook off an install disc, preferably 10.4 Tiger, and see if you have any audible bloops when you increase and decrease the volume.

这个答案有帮助吗?

按维修分数 0
添加一条评论

Although I was very careful with the speaker cable, and everything else, I too get no sound from the speakers after otherwise-successfully replacing the HDD.

However, I also don't get any sound from the headphones either. Can that cable affect headphones too?

Update

To further clarify, I haven't yet had a chance to do much diagnosis of the problem, other than the obvious stuff: Yes, the volume's up, it's not muted, and the correct (and only) sound-output device is selected.

After it finishes a round of Software Updates, I'll try zapping the PRAM (what the heck, may as well).

这个答案有帮助吗?

按维修分数 0
添加一条评论

添加你的答案

riDerz 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 2

过去的30天: 15

总计 6,466