The world’s most famous headphone has been completely redesigned and reimagined. The new Beats Studio is lighter, sexier, stronger, and more comfortable, with precision sound, Adaptive Noise Canceling, a 20-hour rechargeable battery, and RemoteTalk. It has all the energy and excitement you expect from Beats, plus a powerful, reengineered sound.

61 个问题 查看全部

Problem with LED/Charging and Audio Cord

The title might have thrown you guys off a bit but I got a problem with my Beats Studio 2.0 headphones. Basically when I plug in the charger the LED indicator does not show any lights. However if I leave the charger plugged in (still no LED lights at this point) and then plug in the audio cord into the beats headphones the LED indicator starts flashing, appearing as if the headphones are charging. However the headphones do not go past the first light. The first light is clearly there and all the lights seem to be flashing together, with the first light being the brightest and the rest of the lights fading gradually.

So if I plug in the charger and keep it plugged in and then plug in the Audio cable, the headphones will work as long as both the charger and audio cable remain plugged in.

Another weird thing is if I instead plug in the audio cable first and then the charger, the LED battery indicator light (first light only) will flash quickly and then the LED lights will not flash at all. On top of that the audio will not work either so I have to plug in the charger (keep it plugged in) and then plug in the audio cable, thought that was weird.

Anyhow do you guys know of a possible fix? I'd like to let you know that I have two pairs of Beats Studio 2.0 headphones. One of them has a broken headband and bracket but the audio works fine and then there's this one which has no broken parts besides the battery (idk where the battery would be in the Studio 2.0) I guess? Anyhow any help is appreciated.

已回答! View the answer 我也有这个问题


按维修分数 4

所有超过US$100.00或包含 Pro Tech工具包的订单免费送货!





Have you tried resetting your headphones?

Here is a link that shows how to do it.


按维修分数 2


Yes I have tried resetting my headphones several times and still nothing. I plug in the charger, plug in the audio cable and then the first LED light starts blinking and the rest are very dim. Nothing happens at all when I try and reset my headphones.

Alright I think I found a problem, not sure what it means exactly so I'm hoping you could help me out here. Disassembled the battery side of both my beats (the ones that wont charge and only work with the charger plugged in/audio cable plugged in) and my other ones which work but have a damaged headband/earcups.

Anyhow here's a link to the image of the beats that I'm having problems with.

Alright battery doesn't seem to be the issue here, swapped batteries and it charges fine on the circuit board that doesn't appear to be damaged.

Seems to me that I need to desolder a few wires from the working board and the damaged board and then swap them out and then solder the wires to the working circuit board. What do you guys think?


If the working board looks 'clean' that's the way to go. Was about to suggest that you try to clean the damaged board with some isopropyl alcohol on a Qtip. Gently wipe the affected areas, check both sides. Very gently, you do not wish to remove any components off the board. It may be that there is an electrical pathway provided by the 'corrosion?' and by cleaning it you may have it going again. Worth a try if you can before you unsolder things. if it doesn't work you've only lost a bit of time. Also with it clean at least you can compare it with the other board.



I tried holding the power button and the beats button that cancels out sound for about 5 10 seconds and it worked


按维修分数 1


well it worked for me after repeated trials of this method


From our experience this issue can be a circuit board or bad solder joints.


按维修分数 0


oldspice 将永远感激不已

过去的24小时: 32

过去的7天: 164

过去的30天: 855

总计 24,518