Mystery... No sound!... O/I card? Speakers? Logic board?

My MBP 4,1 (model A1260) stopped making sounds suddenly...

I've read hundreds of posts on the internet but nothing seems to help. Here are some symptoms :

- Built-in speakers don't make any sounds.

- No sound coming from output jack (headphones or external speakers).

- The mic (line-in) jack don't work either.

- The power connection and left USB works fine.

-NO RED LIGHT coming from headphone jack... so its not the optical speaker switch problem like most have.

- In "system information", when I look in sound hardware... no description for input, output, etc...

- I tried the Apple Diagnostic Software in the installation CD, the full extended scan... and nothing found.

- Everything else works fine on my computer.

My apple warranty is over :( ...

Before I spend to much money at a computer store, anyone knows how to solve this mystery??

Is it the O/I card? Speakers? Logic board??

Thanks

已回答! View the answer 我也有这个问题

这是一个好问题吗?

按维修分数 6
添加一条评论

GIVE TOOLS. FIX FOREVER.

GIVE TOOLS.

FIX FOREVER.

Spread the Fixmas cheer.

GIVE TOOLS. FIX FOREVER.

Spread the Fixmas cheer.

5个回答

已选择的解决方案

First thing I would try is to boot to your System disk--select disk utility and run disk repair until it reports no trouble found. this will help us pinpoint your problem. Ralph

这个答案有帮助吗?

按维修分数 5

评论:

I tried the disk repair utility, booting from my Snow Leopard DVD. After verification + repair... no problem was found. Also I tried the "Apple Hardware Test", booting from my OEM disc 1 (OSX 10.5.2), and no problem was found either.

Just for the info, when I'm on my bootcamp partition (windows 7), the device manager sees an audio device : Realtek audio. Probably just because of the drivers installed tho... the same sound issues are present.

Bruno

添加一条评论

If Ralphs suggestions did not work, I would replace the I/O Board. It's the next logical step.

这个答案有帮助吗?

按维修分数 4

评论:

添加一条评论

funny story. I have the exact same problem. But, I am pretty sure I know what happened. I was swapping displays (broke my old one, bought a new assembly, long story) and I must have hit something and shorted something out (it was off at the time w/ battery out though I swear) because now I have no wifi nor speakers. Is it possible that I hit a connector and I just need to reconnect it? (Yes, the wifi antennae are connected, unless they're broken) I've tried looking for anything loose, but I have no idea what I'm looking for, so I'm not able to find anything. It just happened tonight. If anybody wants to know more about my predicament (and maybe solve both our problems at once), I'll check back in the morning and do some more prodding.

If it means anything (not sure if it does) but I'm getting a new Left I/O board tomorrow because I may have sorta kinda accidentally bent (and broke) an inverter cable pin. whoops.

这个答案有帮助吗?

按维修分数 2
添加一条评论

Finally I brought my laptop to an apple store. It turns out the problem was my I/O board. I paid for the replacement and everything is back to normal.

Thanks everyone for helping me!!

这个答案有帮助吗?

按维修分数 2
添加一条评论

excellent! thank you! I will give this a try.

这个答案有帮助吗?

按维修分数 0
添加一条评论

添加你的答案

Brled4 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 7

过去的30天: 40

总计 7,093