The Samsung Galaxy S4, model i9505, features a 13-megapixel rear camera, and a 5-inch 1080p display.

635 个问题 查看全部

touch screen won't respond

My touch screen will not register any touch. I have replaced the screen/digitizer TWICE and the mother board. What else is there that controls the screen? The cable gets replaced with the screen and the port with the motherboard. What else is there? The back and home button does work at the bottom of the screen. I have also done a hard reset and cleared the cache.

已回答! View the answer 我也有这个问题


按维修分数 5


mine is an s3 and the touch/swipe doesnt work

My S4 galaxy touch pad was not working either. I took off the back removed battery & sim ect and got Hair dryer and went over back for 5min and also the front screen on a mid heat setting for about 3min. .. It fixed it!. It Seems like I had moisture in between the digitizer and Glass ....I was using it in my SPA a few nights b4. Try A Hairdryer! !!!

I returned from a trip to Central America where it was hot and humid to 50F weather, and after 20 hours it happened to me. Tried everything, even the factory reset. Finally I stuck it into the oven without the cover/battery to warm it up safely (100-150F) for about 10 minutes and it started working! LOL


所有超过US$100或包含 Pro Tech工具包的订单免费送货!




Where are you getting the parts from? It seems unlikely, but you hear lots of stories of people getting two faulty parts in a row when they're buying replacements. I usually suggest giving it one more try with a part from a different seller to see if it will work.

Check out the parts that iFixit sells:

Make sure to match your cell carrier to the part you're buying. You're looking for the "display assembly," which includes the digitizer.


按维修分数 1


Thanks Annette. I thought that too. Each display had different problems, first one had a dead spot in the center of the screen on occasion, second would not register a touch at all except for the home and back buttons at the bottom. I got both display/digitizers from the same eBay store. They had over 10,000 transactions with a 99.9% rating. They sent me the second one with no hassle when I told them the first one seemed to have a problem. Both were in original packaging unopened. I guess that is what I will try again with another company, possibly ifixit.

My S4 has almost the same problem....but only the bottom right part of the screen won't touch and the return and home buttons....but every things else works.. what do I do?

That sounds like two different problems. A faulty digitizer, and a faulty home button. Try replacing the display assembly (including digitizer) and that will include a new home button/home button cable. iFixit has some S4 parts here:

Just replaced the digitizer/screen assembly for the third time. Seems to have corrected all of the problems. Thanks for your help.

some people have been saying that EVEN AFTER replacing the digitizer the phone's screen still isn't working so it's CLEARLY CAN'T be it. can't you people think of anything else????


I had same problem. Nothing worked plus can't remove the battery on my phone. Watched a video that says remove battery and hold down the on/off button for a minute to reset so thought why not. Wow it worked even though battery still in. Yay have all my contacts & diary back. So relieved!!!


按维修分数 3


My 3 years old S4 Active did this. Tried without battery, didn't work. So I just did it WITH the battery and it started working (touchscreen)! It took a few seconds to come back afterwards. After the 60 second reset, I was pressing/releasing the power button and nothing for about 30 seconds. I was ready to run to AT&T and get an S7 for $28/month, now I'm kind of sad I didn't... <-- I'm el cheapo :-)


I updated my moms phone which is a s-4 galaxy.... And it feezed and now the touch screen will not work so I tried to reboot and and take Sim card and battery out and still DOES NOT WORK


按维修分数 0


I had a S4 screen fixed at Axiom in Lynchburg, VA I picked it up & it worked fine for a week or 2 on wifi then took battery out to set upon Sprint & wont work on touch or swipe took back & they tried everything they knew or went back home & reset hardware but still wont work on touch.


Hello All,

fixed by solution on this link on XDA-Forum. it made me crazy and unfortunattely no other solution I have found which worked on my FW of TSKeys ( Phone 0x10, Part: 0x1a ). I used TWRP 2.5 for my phone HW version.

1. Upload Zip files from XDA Link to SD-Card

2. Reboot to download mode and install TWRP by ODIN ( my 3.09 )

3. Reboot to TWRP Recovery mode

4. Select "Install" and add both zip files in order Universal... and then Imperium....

There is button to add next zip file, they are installed in order you added them.

5. Install and rebooot



saved my money for new parts :)

GT-I9505 "Coca-Cola SK"


按维修分数 0



but at point 4 you say "Select Install". This means the touch is working after the install of TWRP?

Because you can do operation 1 to 3 without touch screen, but for the 4 you will need it.



UPDATE: the link at the original post don't work... :-(



aharper42437 将永远感激不已

过去的24小时: 11

过去的7天: 70

过去的30天: 359

总计 40,591