The Microsoft Surface 2 was manufactured by Microsoft Corporation and is the second generation of Microsoft tablets. It was launched on October 22, 2013 and includes features such as upgraded processing power and screen resolution.

32 个问题 查看全部

(Plugged in, Not Charging) Error. Help?

I just bought a surface 2 last night and there is an issue, I plug in the power cable, but when I see the battery indicator, it shows "plugged in, not charging". The tablet turns off if I unplug the power cable..

I've tried the following workarounds that I found online:

1) shut down the tablet, unplug the power cable and leave it for few minutes, plug in back the power cable and let it charge for few minutes, turn it on.

2) shut down the tablet, press volume up + power button for 10 seconds, leave it charging for few minutes, turn it on.

3) Performed a full system recovery.

But sadly these didn't help. I would like to ask is there any other workaround I can try?

I have tried multiple outlets as well as multiple chargers.

Thank you.

已回答! View the answer 我也有这个问题


按维修分数 15


I had this issue on my Surface RT after replacing the motherboard. After trying everything, this worked for me.

This was my last resort, I should've made it my first.

1- Exercise extreme caution!!! Keep RT plugged connected to the charging cable.

2- Using you're electronics tool kit, properly remove back cover and label the screws.

3- You may notice that while the battery is connected to the motherboard and you slowly move the back cover away, the battery is detected. If you experience this then my solution will work for you.

4- Cut three small pieces of paper and insert them on all sides of the curved connector. It seems that there is some kind of disturbance there and the paper will fix it. Message me if you need further instructions.

That's a crazy solution. I would suggest having Microsoft replace the tablet!

problem solved. All you have to do is plug cord in to computer before you turn on the power, or plug it in. Works every time!!!

sorry Barrygroom, that not a fix that works.

Well, Barrygroom, it worked for me! (Surface Book)



所有超过US$100或包含 Pro Tech工具包的订单免费送货!




I ended up finding a solution on a few forums. When the error massage (battery not detected) is showing in the desktop icon on tast bar, unplug the charger (tablet will shut off) hold down power button about 10 seconds and while still holding it plug the charger back in. When the surface logo appears let go of power button. That will then give you the "plugged in, not charging" message. Repeat the steps and it will eventually work. After it was at 45% i unplugged it and plugged it back in. It worked and was charging well but after unplugging and plugging back in several times i noticed sometimes it would not charge. It is just a matter of plugging in and unplugging the charger in my experience. Ive heard many other people having the same problem and getting around it doing the steps i suggested.


按维修分数 20


That worked for me. Thanks

This worked perfect, Thanks for the post

Thanks man. I have battled with this for 2days now. It just worked

i dont understand when do u shut it down and when do u plug it back in im wandering because my tablet when i plug it in it just doesnt charge it first say pluged in not chraging then nothing else pls help

worked perfect ty




Have you only a plug in symbol without the battery symbol ? please follow tha steps in this link surface-battery-wont-charge !.

if you done that and no result ,then is one of three your charge kabel maybe is broken or Check the connectors on both the power supply's connector and on the charging port (on the side of Surface itself) ! at the end of IS THE BATTERY ! IS BROKEN ! .

Please go exactly according to the instructions on the page!

and tell me about it if what needs to be repaired, I'll help you.

I'd bet more on the battery it is broken!

sorry for my bad english!

best regards, murrx


按维修分数 3


Tried it and got a symbol with low battery, stays on for 3secs and goes off, the little light flickers and goes off... what should i do???

how do u know the battery itself is broken and not the internal chariging circuits?

i'm on my 4th charger now.. it seems the heat generated on the surface port and the charger connector plus dirt makes the plastic on the connector expand making the pins stuck up.. a regular connector is so much better than a magnetic one.


Hi, I had this issue as well. After much searching and conflicting info (even on Microsoft site) I eventually found the answer.

Problem. Charger connected, right swipe showed power connected but empty battery. Unplugging charger meant Surface 2 RT shut down. Connect charger and power up, got repair message.

Solution that worked for me. Went into Device Manager (Search Device Manager), deleted the second entry under the Battery section. Shut down the Surface completely. Plugged in charger, waited 20 minutes and now there is a white line showing in the battery icon. Waited another 20 minutes and the white line is thicker - enough to allow updates to download and install.

As part of the problem solving over some hours, I had reset the Surface to factory default - which was probably not a bad idea anyway as a rebuild often corrects most problems (but not in this case). Hopefully this will help others.


按维修分数 2


is there anyone who follow this workaround?

i afraid to delete ACPI section.

is it real???

worked for me on Nokia 2025

it worked on my surface 2. I bought it refurbished and once i disabled and deleted the second battery selection (2 listed exactly alike) it charged completely and finally allowed me to complete the firmware update.


I got the same problem before

And I was plugging the charger plug up side down

and that was the reason when I return it to the right position the problem was fininsh

the lamp in the charger must be up and the wire down when you plug it to your tab

best wishes


按维修分数 1

Hi all,

I found that this was a bug related to the detachable screen. Have you tried to detach the screen? In case you have below 10% charge you can do it manually. Here is a video how to handle

Once you have attached it back up try to plug in the charger and see if the status is changed back to "plugged in and charging".




按维修分数 1


This worked perfectly. I must have hit the DETACH key and didn't notice. A great solution would be for the DETACH process to auto-re-attach if it isn't removed in a certain amount of time.


I have a surface pro 2.5 windows 10 with 2 charging issues

Issue 1. charger will light up for a few seconds then stop charging:

Cause: AC cord from wall to brick, I'm in the Philippines and I don't want to pay for shipping, easier to make or buy a new one.

My Solution: I had to shave the plastic and rubber parts of the male plug that goes into the brick so its in deep. I now get a steady charge light but after windows load i gets Issue 2

Issue 2. Plugged in Not charging:

Cause: windows 10 auto update of drivers (even if disabled, no go, it will still update)

My Solution: (temporary, still looking for a better one)

Before every shutdown, uninstall all battery and bluetooth drivers (device manager, put check on delete drivers) after shutdown, vol up + power button till it blinks twice(full shutdown), disconnect charger (don't power-up right away!).

Before power-up, reconnect charger and power on, on boot-up windows will auto install default drivers so the bluetooth and charger will work.

Once you go online new drivers will auto download and install and once restarted or shut, a full install will happen and you will again get the same issue. To avoid that I do the same said shutdown and power on procedures I formulated thru hours of trials and reading. Hoping that a new update will finally resolve this.


按维修分数 0

This site sucks...I filled out an answer but then was prompted to create an account. After creating my account my thoughtful explanation was nowhere to be found.

Anyways, in short, the internal battery connector on my Surface LTE is loose / disconnected. It would say it's plugged in, not charging. The light on the charger turns on, the screen brightness changes according to my power plan...the computer knows it's plugged in....but power just isn't getting where it needs to.

I just pressed on the back around where the power connector is and it instantly started working. When I open it up, if this is the case, I'll slip a few pieces of paper to keep the connector snug and connected so this doesn't continue to happen.


按维修分数 0

I just tried the below from and it then started charging battery 1.

To perform a two-button shutdown on your Surface Book, do the following:

Turn your Surface Book off.

After your Surface turns off, press and hold the volume-up button and the power button at the same time for at least 15 seconds, then release both (The screen might flash the Surface logo, but don’t release the buttons for at least 15 seconds).

After you release the buttons, wait for 10 seconds, and then press the power button again to turn on your device.

One you performed a two-button shutdown, try to detach your Surface Book from the keyboard, and it should work without any problems. In case you’re still unable to detach it, try some of the following solutions.


按维修分数 0


okay so I have the Nokia Windows tablet. It is saying plugged in but not charging. I have tried the power off volume up battery reset also a hard factory reset. I've done a plug in while turn on. a shut down plug in unplug plug in power on and still nothing is working. Does anyone have any suggestions on something I can do to get it to hold a charge. Thank you in advance



Rush 将永远感激不已

过去的24小时: 221

过去的7天: 1,602

过去的30天: 6,799

总计 301,443