Late 2011 model, A1278 / 2.4 GHz i5 or 2.8 GHz i7 processor.

501 个问题 查看全部

locked hard drive can't reinstall Lion OSX

I bought a used MacBook and I wanted to do a factory recovery. I restarted and held down command + R. I went to disk utility and erased Mac OS extended journaled. I restarted and I clicked on reinstall Lion OS. when I click on the hard drive and it states Hard drive Locked, I am unable to do anything.

已回答! View the answer 我也有这个问题

这是一个好问题吗?

按维修分数 16

评论:

my mac book pro did not have the option enable journal available to select it was grey, it was there but could not select it, so i externally formatted the hard drive NTFS type, then formatted it again internally with the mac, then started the installation again and it worked (mac lion OS)

How do you do that if you don't mind me asking

I suspect he was able to attach the drive to a Windows system to reformat it the NTFS which got rid of the damaged boot sector. Then with the drive back inside his Mac he was able to reformat the drive using either a OS install DVD the system came with (grey disk) or the retail version. The other way would be using an external bootable OS-X drive (USB, FireWire or Thunderbolt).

I've created a bootable USB thumb drive just for doing this. While slow it does get the job done. On it I have a copy of Disk Utility and the OS installer to then run to prep and install a fresh copy of the OS.

I took the disk oft of the mac and installed it in an external disc-cabinet.

Connected it to another mac, where I was able to recreate the partition.

I copied al the partitions data to the other mav before recreation, and copied it back afterwards. I don't know wether that was necessary.

I had to hold Cmd-R when starting it, and use Applestore for installation.

I'm happy it worked out!

Another option would be connecting your system to the other back to back via a FireWire or Thunderbolt cable and then setting up your system in Target mode that way you would be treating your system as if it were an external HD to the other system saving the effort of pulling the drive out.

显示更多的2条评论

添加一条评论

所有超过US$100或包含 Pro Tech工具包的订单免费送货!

浏览我们的商店

8个回答

已选择的解决方案

In disk utility, click on the hard drive then click 'enable journaling' it should unlock the drive

这个答案有帮助吗?

按维修分数 16

评论:

Thank you, I have enabled journaling and it worked!!! Mayer, Dan, & Waseem greatly appreciate your help!!!

edie - I surmise you didn't select the correct format option to start with which is why the disk was locked. Not a very informative error message was it ;-}

I have same problem but "enable journaling" is also grey...what should I do then..??

Are you booting up on an external drive? You need to get there first. Then run Disk Utility to alter it.

I am not running the computer in normal mode and no external drive. I start it by pressing command+R key because normal mode isn't working.

显示更多的12条评论

添加一条评论

Do you have access to a second Mac? If you do you could try starting yours in target mode and use the other to install the OS via a FireWire, USB or Ethernet back to back cable.

这个答案有帮助吗?

按维修分数 5
添加一条评论

Same problem except that I am a 25 year Macintosh consultant and this has me stumped, I can use Data Rescue to see and recover all the files I need.

The two drives that have the lock on, are internal macpro drives this happened four days ago.

I did not do it

I am fully aware of all of the ways to change permissions on the drives They all have a custom permission and when I try to change it to specify a user or admin as read and write they all go back to custom, and Yes I unlocked the get info before I tried.

My Data Rescue Program says that the data was changed 2/5/40 "I say what the"

This is the message that I get after running data rescue

@@@@HFS+ Private Data 2/5/40

The previous date was 2/10 2015 before the message above

I have also used the terminal program to try and access and unlock the drives I do not have the code at hand at this moment

Just another friggin Apple problem, that probably has no solution.

sometimes I wish they would fire all of the nerds that are now in place and hire back the old ones. At least they the old ones had caring about users in mind they tried to solve problems instead of creating them. The New Yosemite and Lion and Montain Lion and Mavericks have done nothing except mess with older computer users and the programs that no longer work. Now all we have are a bunch of I phone idiots walking out into the streets with their eyes glued to their %#*@ phones. Einstein said "We Cannot solve problems using the same kind of thinking we used when we created them"

这个答案有帮助吗?

按维修分数 4

评论:

Sometimes the simplest fix is the answer here. Prep up a bootable USB thumb drive. Then after booting up with it run Apples Disk Utility from the thumb drive. Select your internal drive and run repair permissions and then disk you will likely need to run it a few times. Let us know how it goes, nine out of ten times this fixes things. If not you likely have a drive that's going.

I prepped a bootable thumb drive. It won't let me start up from that.

You'll need to disconnect the internal drive so it will boot up via the USB thumb drive. Then go into system prefs Startup Disk alter it to the USB drive now shutdown the system reconnect the internal and reboot that should fix it.

Okay, I'll try that, Dan.

i have same problem but am an amateur, how do i disconnect the internal drive first?

显示更多的3条评论

添加一条评论

Try changing the RAM configuration by pulling one stick. Then on the first restart, reset the PRAM.

Here's how to do it: http://support.apple.com/kb/HT1379

这个答案有帮助吗?

按维修分数 2

评论:

I did what u suggested and nothing. Still getting error message "This disk is locked" when I try to reinstall Lion.

How to get back my MacBook normal screen when it displays padlock sign?

@k7004205773083 Please start a new question and give your specifics as an answer here would get lost. Give your exact machine as methods differ and there are different types of locks. The lock discussed here sounds different from yours. A photo of the locked screen really helps.

添加一条评论

Just boot from the lion, use terminal window to run the unlock command of the logic volume.

Follow the procedure in this blog

https://derflounder.wordpress.com/2011/1...

After this format the drive with non encrypt format, then you good to go.

这个答案有帮助吗?

按维修分数 0
添加一条评论

My symptom was it was asking for the password but I couldn't type ANYTHING in the field so I powered off and powered on holding Command + r down for 15 seconds and let go of keys and went into Disk Utility and formatted the drive "journaled" and then was able to reinstall Sierra.

这个答案有帮助吗?

按维修分数 0
添加一条评论

how i can solve this problem

这个答案有帮助吗?

按维修分数 0
添加一条评论

when you unlock by journaling do you lose your data files?

这个答案有帮助吗?

按维修分数 0
添加一条评论

添加你的答案

edie 将永远感激不已
浏览统计数据:

过去的24小时: 25

过去的7天: 182

过去的30天: 809

总计 247,477