跳转到主内容

Model A1311 / Mid 2010 / 3.06 & 3.2 GHz Core i3 or 3.6 GHz Core i5 Processor

315 个问题 查看全部

LCD not working after ssd installation

Hi there,

after succesful installation of a ssd, I damaged display data cable and afterwards the the lcd of my imac stays black. Computer is booting and running normal, an external display shows picture.

Diagnose LED4 stays black, all others are green.

I already bought a new display data cable and a new backlight inverter board but both with no result - the lcd stays black.

No i´m wondering what it could be, because I don´t want to buy a new lcd if it´s not necessary and I already spent a lot of money with no result.

Every help is very much appreciated.

Sorry for my bad english, I´m from germany ;-)

回答此问题 我也有这个问题

这是一个好问题吗?

按维修分数 0
添加一条评论

Macbook 电池维修套装

起价 $69.99

Buy Now

Macbook 电池维修套装

起价 $69.99

Buy Now

2个回答

It is unfortunately very common for people to damage either their display cables or the actual display cable connector on the logic board. I can only speculate because I cannot examine it myself, but I would be willing to bet that you accidentally damaged the connector on the logic board, which could possibly require professional soldering skills to repair.

Does the connector look damaged at all? If the connector looks fine, try to examine the pins inside it. Are any of them bent or out of place?

If you look at the guide to remove the display, iFixit warns that the display data cable and display data connector are very easy to damage, and in the comments below, other people agree.

这个答案有帮助吗?

按维修分数 0
添加一条评论

The connector does not look damaged. Also the inside seems to be ok but that´s hard to say. I cannot see an obvious damage.

这个答案有帮助吗?

按维修分数 0
添加一条评论

添加你的答案

delbracht 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 0

过去的30天: 0

总计 202