Model A1286. Released February 2011 / 2.0, 2.2, or 2.3 GHz Quad-core Intel Core i7 Processor

528 个问题 查看全部

No power no sound no boot after battery replacement

I used istat pro to help indicate my battery was not holding a charge very well. I looked up all the correct information and bought the correct battery for my computer online.

After properly shutting down my computer I followed all the steps on this website to replace the faulty battery for the new one. After reassembly the computer won't boot whatsoever. No sound no picture no fan, nothing. Even when using the old battery it still won't boot. The battery indicator on the side indicates there is battery and when plugged in with the original Mac power cord the light on the MagSafe is green.

Is this a logic board issue? Did I messes something up?

What can I do to fix this?

已回答! View the answer 我也有这个问题

这是一个好问题吗?

按维修分数 0
添加一条评论

GIVE TOOLS. FIX FOREVER.

GIVE TOOLS.

FIX FOREVER.

Spread the Fixmas cheer.

GIVE TOOLS. FIX FOREVER.

Spread the Fixmas cheer.

1个答案

已选择的解决方案

Double check the MB top case connection to the logic board. If this ribbon cable is not fully inserted to its socket then power button will not work and no power to the macbook.

这个答案有帮助吗?

按维修分数 3

评论:

Thanks for you're reply lemerise. Which cable is this exactly? I have triple checked all connections on the logic board. And have had no further success.

On further inspection I noticed when I hold the power button I hear a very faint clicking noise coming from the fan area of the logic board. I don't know what that means.

OK so the logic board seems to receive power. Did you try a SMC reset ?

I've tried an smc reset a couple times although this does nothing. I have no warranty for this computer so bringing it to apple repair is a last resort

Also if i plug the magsafe in the light stays a consisten green

Find the two power pads on the logic board (most of the time they are located near the top case connector) and with a multimeter settled to DCV/20 put the black probe on any logic board screw for ground and the red prob on one of the two power pads. Try this with the battery disconnected from the logic board. With the AC adapter connected the reading should be 3.42 volts (G3hot power line) on one pad and 0 volt on the other. If you don't get that reading the logic board wont power on. If you don't have this reading, disconnect the AC adapter, disconnect the top case ribbon cable, connect the AC adapter and double check the power pads voltage. If you still don't get the 3.42 volts you should remove the logic board and check the magsafe dc in board voltage and the main power fuse near the magsafe board connector.

显示更多的1条评论

添加一条评论

添加你的答案

Xander Budnick 将永远感激不已
浏览统计数据:

过去的24小时: 1

过去的7天: 3

过去的30天: 28

总计 3,891