跳转到主内容

Model A1225 / Mid 2007 and Early 2008 / 2.4, 2.8, or 3.06 GHz Core 2 Duo processor

490 个问题 查看全部

Diagnostic led 1 stays on until hard drive plugged in

My mid-2007 iMac 24" 2.4 Ghz stopped working.

It would just shut down after being on for a few minutes, and eventually wouldn't power on at all.

I did some reading (big thanks to all the contributors at iFixit - such a great resource!) and learned about the 4 diagnostic LEDs inside the computer.

I opened up the machine and saw that the first LED was turning off after a while. I removed the hard drive and noticed that the first LED was now staying on all the time. Could the hard drive be drawing too much power or something? I tried another hard drive and had the same thing happen.

If I put the hard drive into a Firewire enclosure, I can boot off of it, and the computer does not shut down.

I'm hoping someone here (Mayer!) can give some advice as to what I might do to repair the iMac.

Thanks!

Update

Update: now, led 1 doesn't stay on for more than a few seconds.

Is there a way to determine if it's a power supply problem or a motherboard problem? I'm willing to replace the power supply but the motherboard is probably more than the computer is worth.

已回答! View the answer 我也有这个问题

这是一个好问题吗?

按维修分数 1
添加一条评论

iPhone 电池维修工具包

只要 $29.99

Buy Now

iPhone 电池维修工具包

只要 $29.99

Buy Now

1个答案

已选择的解决方案

Sounds to me like a failing power supply. How are your diagnostic lights when booted from your firewire drive? Try booting from your original system installation disk and run Disk Utilities on your firewire hard drive and see if it has issues.

这个答案有帮助吗?

按维修分数 2

评论:

I agree. My power supply was bad, which in turn took out the logicboard. So get it fixed ASAP.

添加一条评论

添加你的答案

jeremy767 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 0

过去的30天: 0

总计 833