跳转到主内容

Model A1285 / 8 or 16 GB capacity

194 个问题 查看全部

Click Wheel works for restart, but not single button.

I have an 8 gig here, trying to repair it for a friend-the initial problem was the click wheel was unresponsive for everything except restarting. no diag screen, (center+left) no disk mode (center+play/pause) no single button use. I ordered a replacement click wheel guts, replaced it, and it did not work at all. could this be a click wheel problem, and ordering a new one would fix it? or should I try to get a new board?

I've gleaned that these nanos have click wheel problems a lot.

已回答! 显示答案 我也有这个问题

这是一个好问题吗?

得分 1

评论:

I am a very mechanical person, and have worked on small electronics my entire life. I must say, the ipod 4th gen is a total PITA with regards to assembly, disassembly. I have trashed THREE of the #^$& click wheel films just trying to get the &$^* thing apart/back together. I'll stick with repairing the traditional removeable back styles and leave the 4th/5th generation to the insane.

完成的

添加一条评论

7个回答

已选择的解决方案

I don't know how much help this will be since your post is 2 months old, but maybe it'll help someone else.

I had the same problem. Just get some isopropyl alcohol and swab the connector that connects the click wheel flex cable and the logic board. Also I'm not sure what you mean by click wheel guts, maybe the flex cable for the click wheel? Anyhoo, I have a friend who let me fix his iPod nano and he accidentely ripped the flex cable for the click wheel so I'm going to do a replacement and see if that works. I'll post updates later.

这个答案有帮助吗?

得分 2

评论:

Thanks dude! I'm not sure as to how that will work, I've given up on it and she doesn't care. BUT I do have a few extra click wheels now, so that's cool. We'll see if it helps in the future.

完成的

添加一条评论

@tabormeister

I have completly same problem with yours. I have replace the click wheel still it does not work. I cannot log on diag menu but I can restart (select+menu). And I can wake the ipod up while press the any button.

Sorry for my english.

Regards.

这个答案有帮助吗?

得分 0
添加一条评论

I've seen this issue to, a lot. but have yet to find a solution. It's something to do with the logicboard rather than the clickwheel or either of the ribbons that much i do know.

Are people experiencing this problem mainly on water damaged units or is there just a problem in the design/manufacturing of some of these nano's that leads to this?

这个答案有帮助吗?

得分 0
添加一条评论

If you think the fourth generation is tough you should try the fifth.

I once had the task of mounting tropical spiders web on bits of half inch square card. We put them in a machine we were designing to measure breaking strains of picocoulombs.Nothing compared to that nano!

这个答案有帮助吗?

得分 0
添加一条评论

Look elsewhere in Ifixit for the credit card fix for the 4th gen click wheel problem. Worked for me and it is simple to do.

这个答案有帮助吗?

得分 0
添加一条评论

would anybody tell me where can i get a click wheel???? i m from Pakistan pleez help.

这个答案有帮助吗?

得分 0

评论:

eBay, friend.

完成的

添加一条评论

I am experiencing this same issue with my fifth gen iPod Video. Managed to sever the ribbon cable to the click wheel when taking it apart to repair the headphone jack long ago. Click wheel was find prior to this "repair". Decided to revisit the thing and ordered a new click wheel to see if I could revive it. I was able to successfully put it back together with the new part but still no response on the click wheel other than soft reset. Would love to be able to utilize the thing again. I might try the alohol swab idea and the plastic credit card hack just out of desperation. I'm beginning to be convinced that its now the board. I will update if anything works for me. Anyone with more input on this kind of problem??

这个答案有帮助吗?

得分 0
添加一条评论

添加你的答案

tabormeister 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 1

过去的30天: 3

总计 4,360