Revamped version of the iPhone 3G with faster processing speeds. Repair of this device is similar to the 3G, and requires simple screwdrivers and prying tools. Model A1303 / 16 or 32 GB capacity / black or white plastic back.

1959 个问题 查看全部

Weird sound problem with iPhone 3GS

I replaced the dock connector in my 3GS due to a bad antennae. After replacement I get no sound when watching youtube or videos I have recorded.

However, my phone rings, I can hear/talk on phone calls via the earpiece, speaker phone and headphones

Any ideas?

已回答! View the answer 我也有这个问题

这是一个好问题吗?

按维修分数 0

评论:

I reseated the connectors and restored.... still nothing.

Doesnt even show a volume control on youtube or videos I had taken before.

I press the ringer up/down buttons and it does nothing either.

You may have not connected the ringer up/down buttons right, reconnect those and exchange the antenna and before the phone goes back together, verify the connectors inside

I have gotten bad dock assemblies off of eBay. Irritating as it may be u could have gotten a bad part

添加一条评论
传播 Fixmas 欢乐
Get $12 off your purchase of $50 or more with code FIXMAS12
传播 Fixmas 欢乐
Get $12 off your purchase of $50 or more with code FIXMAS12

1个答案

已选择的解决方案

Try rseating the connector

If that is no help, it is a defective part or another part is bad in the phone

Let the phone do a backup if that does not work and restore it

If that is no help, it is going to be something to do with the logicboard

How did i come up with this?

I ruled out a new dock connector, then i thought a restore could do something, and yes i thought ahead that it's hardware in the phone somewhere

All a iPhone is a battery, dock connector, logicboard, earpiece, digitizer, screen, proximity sensor(s)

update

Although you recently restored, you may have to again, you may want to reseat any connectors in the phone first

这个答案有帮助吗?

按维修分数 1

评论:

The restore on the phone was a few days old (not used at all however other than making sure everythign worked)

It worked before I replaced the connector, just not now.

I was under the assumption that the external speaker is what would be bad, but It does work on speaker phone. Am I wrong about this?

Reseat the connector then if that is no luck, I would try another restore, then update your question with the results of that

添加一条评论

添加你的答案

Andy 将永远感激不已
浏览统计数据:

过去的24小时: 0

过去的7天: 0

过去的30天: 1

总计 1,130