Pc will not boot up

I have a mpc clientpro 545 and i had windows xp on it i turn it on and my fan and cpu fan run constantly and i dont get any boot logos i have a black screen what can i do to fix this please help


ok today i went on the cpomputer ddid the thing with the battery and it didnt work i took the battery out and the jumper off after i tried just the battery and turned ir n and it worked but got nothing on my screen the cpu fan turned off and the cylinder symbol next to thepower button was lit up orange when it turned on i got one beep then when i pressed the power button it immediately shut off when i turned it back on i got no beep and the cylinder did not glow orange and when i press the power button it did not shut off i have to hold it for five seconds to shut it off when i turn it on i have the fan and cpu fan running constantly and nothing on the screen i do not know what happened to it it was working fine and now i have this problem with it ok i will wait for a response ill check back tomorrow for an answer that might help me with this probem ok thanks for helping i am looking forward to providing you with all the information that you need to help me ok bye


Ohh and i have windows xp on it not had i turn it on and there are no beeps just the cpu and regular fan constantly run when i press the power button it does not shut off but i will try these steps that you have provided me so i can see if i can fix this

已回答! View the answer 我也有这个问题


按维修分数 0


you say "had windows xp on it. did you try to remove it or is it past tense because you can not access it?

I have two MPC computers and access to two more, all with the intermittent problem of not powering up when the power button is hit. The green power light is on, but no fan or disk drive.

The problem on all four of these computers is that the power cord/or power input to the computer is not connecting properly. And the solution for all four is to re-seat the power cord. Funky as it sounds, this solution has worked on all four for over a year now. These computers are seldom off, so the problem occurs infrequently, if at all.

Computer one will start if the power cord is disconnected from the computer and then connected up again. Computer two, solution is disconnect, and reconnect, making sure that the plug is fully, and I do mean fully, pushed in. The third respond to the plug just barely inserted. The four has a mind of its own and responds after several disconnects and connects.

All of these computers are between 3-5 years old. In all cases I did not have to work with the video card, power supply or bios battery.

Give it a try.

Bill Jones


所有超过US$100.00或包含 Pro Tech工具包的订单免费送货!



与 #ImAGenius 分享您的维修故事


与 #ImAGenius 分享您的维修故事



Besdies the great points that Richdave makes, I would also try this:"Certain changes in BIOS settings (such as chipset timing or latency, memory timing or latency, processor clock frequency, etc.) can cause a system to no longer boot.

If you are able to enter the BIOS Setup by pressing F2, reset the BIOS to factory defaults by pressing F9. Save and exit the BIOS Setup.

If you cannot enter the BIOS Setup, clear the CMOS:

Turn off all peripheral devices connected to the computer.

Disconnect the computer’s power cord from the AC power source (wall outlet or power adapter).

Remove the computer cover.

Locate the battery on the board (see figure below).

With a medium flat-bladed screwdriver, gently pry the battery free from its connector. Note the orientation of the “+” and “-” on the battery.

Wait one hour then replace the battery.

Replace the computer cover.

Plug the computer and all devices back in.

You may also need to perform a BIOS Recovery after clearing the CMOS." from here with more info about your motherboard. Let us know what works and what does not so we can continue to try to assist you.


按维修分数 6


Ok i will try these tips thank you i will get back to you

I will give that a try in the morning. I'll let you know.


Do you get any start up beeps? If so how many?

May be a video issue. Can you check/confirm the monitor is OK. Swap input, cable etc and advise.

THESE MANUALS may give you some assistance.

Be sure to post back your findings to allow follow up help if required.


按维修分数 3


i have posted my findings above

Try removing and re-seating the RAM - manual suggest removing AGP VGA for better access to RAM so remove/reaeat the VGA as well.

Try different RAM if you can. Can you test your VGA in another machine?

what is the AGP VGA and i do not have another machine to test it on and i do not have any other ram

Sorry - AGP = Accelerated Graphics Port - card slot the VGA sits in, VGA = Video Graphics Adapter - Video card. pull out and reseat the video card and pull out/reseat the RAM. If you have more than 1 RAM module, try booting with 1 only, then try the other, then try each module in turn in each available RAM slot to see if we have a RAM module faulty or a slot faulty

ok i will try but i dont think that that is the problem i had it working before and now i have this problem but i will try to see if it helps



This is me I had to make a new account forgot the password to my account (skulls2rock) I will do the battery thing and see if I download the bios recovery file put it on a USB remove the jumper plug the computer back in and see if I get anything


按维修分数 0


skulls2rock 将永远感激不已

过去的24小时: 0

过去的7天: 0

过去的30天: 10

总计 1,342